summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/rhino')
-rw-r--r--dev-java/rhino/ChangeLog9
-rw-r--r--dev-java/rhino/Manifest6
-rw-r--r--dev-java/rhino/files/00_dont-fetch-swing-ex.patch10
-rw-r--r--dev-java/rhino/files/digest-rhino-1.5_rc52
-rw-r--r--dev-java/rhino/rhino-1.5-r5.ebuild6
-rw-r--r--dev-java/rhino/rhino-1.5_rc5.ebuild41
6 files changed, 69 insertions, 5 deletions
diff --git a/dev-java/rhino/ChangeLog b/dev-java/rhino/ChangeLog
index b843c1011d32..2bf0ed64aba1 100644
--- a/dev-java/rhino/ChangeLog
+++ b/dev-java/rhino/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-java/rhino
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/ChangeLog,v 1.9 2004/05/09 22:04:01 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/ChangeLog,v 1.10 2004/06/19 23:23:42 karltk Exp $
+
+*rhino-1.5_rc5 (20 Jun 2004)
+
+ 20 May 2004; Jason Wever <weeve@gentoo.org> rhino-1.5_rc5.ebuild:
+ Renamed properly, but this plays tricks on the emerge upgrading. Removed ugly
+ autodownload at build time feature, fixes #50615, thanks to Sven Wegener
+ <swegener@gentoo.org> and Thomas Matthijs <axxo@keanu.be>.
09 May 2004; Jason Wever <weeve@gentoo.org> rhino-1.5-r5.ebuild:
Added ~sparc keyword to resolve bug #50403.
diff --git a/dev-java/rhino/Manifest b/dev-java/rhino/Manifest
index 4f6625ecf827..5d8a677beed5 100644
--- a/dev-java/rhino/Manifest
+++ b/dev-java/rhino/Manifest
@@ -1,5 +1,7 @@
-MD5 b48ecb4144a4ca9bff32d491c6688bbc rhino-1.5-r5.ebuild 1365
-MD5 907b0ce974f3f2a0f73006dfea8ee59b ChangeLog 1432
+MD5 fa6445c414d7ebeaea4bde062a571edd ChangeLog 1700
+MD5 7e42a37e078747c40c1966c05a93c8bd rhino-1.5_rc5.ebuild 1269
MD5 4622606981d4aa0930c917b65cf2f202 metadata.xml 350
MD5 2f216cc7ea2b6e2b8356aa3a1fee7c14 files/digest-rhino-1.5-r5 60
MD5 c663f3b82777d7ee2506dc0a03955198 files/jsscript 123
+MD5 0a5ef83b30538dd468f24d14be07769f files/00_dont-fetch-swing-ex.patch 604
+MD5 6d48e39fc85ff462180102a36f8fc589 files/digest-rhino-1.5_rc5 126
diff --git a/dev-java/rhino/files/00_dont-fetch-swing-ex.patch b/dev-java/rhino/files/00_dont-fetch-swing-ex.patch
new file mode 100644
index 000000000000..994975149dd0
--- /dev/null
+++ b/dev-java/rhino/files/00_dont-fetch-swing-ex.patch
@@ -0,0 +1,10 @@
+--- toolsrc/build.xml 2004-03-25 15:54:34.000000000 +0100
++++ toolsrc/build-patch.xml 2004-06-19 23:48:07.225123288 +0200
+@@ -20,7 +20,6 @@
+ <!-- Download source from Sun's site, unzip it, remove
+ the files we don't need, and change the package
+ -->
+- <get src="http://java.sun.com/products/jfc/tsc/articles/treetable2/downloads/src.zip" dest="${nest}/${build.dir}/swingExSrc.zip"/>
+ <unzip src="${nest}/${build.dir}/swingExSrc.zip" dest="${src.debugger}"/>
+ <delete file="${src.debugger}/FileSystemModel2.java" />
+ <delete file="${src.debugger}/MergeSort.java" />
diff --git a/dev-java/rhino/files/digest-rhino-1.5_rc5 b/dev-java/rhino/files/digest-rhino-1.5_rc5
new file mode 100644
index 000000000000..bd31613bb165
--- /dev/null
+++ b/dev-java/rhino/files/digest-rhino-1.5_rc5
@@ -0,0 +1,2 @@
+MD5 af27c07d75bd1697883691318e6da70d rhino1_5R5.zip 1522154
+MD5 ab016c8f81812bb930fc0f7a69e053c5 rhino-swing-ex-1.0.zip 19708
diff --git a/dev-java/rhino/rhino-1.5-r5.ebuild b/dev-java/rhino/rhino-1.5-r5.ebuild
index e7e2f27dcbe7..c89cfce728da 100644
--- a/dev-java/rhino/rhino-1.5-r5.ebuild
+++ b/dev-java/rhino/rhino-1.5-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.4 2004/06/17 10:45:08 st_lim Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5-r5.ebuild,v 1.5 2004/06/19 23:23:42 karltk Exp $
inherit java-pkg
@@ -10,7 +10,9 @@ SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/js/${MY_P}.zip"
HOMEPAGE="http://www.mozilla.org/rhino/"
LICENSE="NPL-1.1"
SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64 ~sparc"
+# karltk: This is deprecated, but we can't just remove it, since we don't have a stable
+# to replace it with.
+KEYWORDS="-*"
IUSE="jikes doc"
S="${WORKDIR}/${MY_P%%RC1}"
DEPEND="dev-java/ant
diff --git a/dev-java/rhino/rhino-1.5_rc5.ebuild b/dev-java/rhino/rhino-1.5_rc5.ebuild
new file mode 100644
index 000000000000..683c21f5ff88
--- /dev/null
+++ b/dev-java/rhino/rhino-1.5_rc5.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/rhino/rhino-1.5_rc5.ebuild,v 1.4 2004/06/19 23:23:42 karltk Exp $
+
+inherit eutils java-pkg
+
+MY_P="rhino1_5R5"
+DESCRIPTION="Rhino is an open-source implementation of JavaScript written entirely in Java. It is typically embedded into Java applications to provide scripting to end users"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/js/${MY_P}.zip http://dev.gentoo.org/~karltk/projects/java/distfiles/rhino-swing-ex-1.0.zip"
+HOMEPAGE="http://www.mozilla.org/rhino/"
+LICENSE="NPL-1.1"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64 ~sparc"
+IUSE="jikes doc"
+S="${WORKDIR}/${MY_P%%RC1}"
+DEPEND="dev-java/ant
+ >=virtual/jdk-1.3
+ jikes? ( dev-java/jikes )"
+RDEPEND=">=virtual/jre-1.3"
+RESTRICT="nomirror"
+
+src_unpack() {
+ unpack ${MY_P}.zip
+ cd ${S}
+ mkdir build/
+ epatch ${FILESDIR}/00_dont-fetch-swing-ex.patch
+ cp ${DISTDIR}/rhino-swing-ex-1.0.zip build/swingExSrc.zip || die "unpack error"
+
+}
+
+src_compile() {
+ local antflags="jar"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compilation error"
+}
+
+src_install() {
+ dobin ${FILESDIR}/jsscript
+ java-pkg_dojar build/*/js.jar
+ use doc && dohtml -r docs/*
+}