summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/bsf/bsf-2.3.0-r2.ebuild')
-rw-r--r--dev-java/bsf/bsf-2.3.0-r2.ebuild29
1 files changed, 15 insertions, 14 deletions
diff --git a/dev-java/bsf/bsf-2.3.0-r2.ebuild b/dev-java/bsf/bsf-2.3.0-r2.ebuild
index b97a1fb4e9c0..935222e5f860 100644
--- a/dev-java/bsf/bsf-2.3.0-r2.ebuild
+++ b/dev-java/bsf/bsf-2.3.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/bsf/bsf-2.3.0-r2.ebuild,v 1.5 2004/10/29 03:13:56 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/bsf/bsf-2.3.0-r2.ebuild,v 1.6 2004/11/16 00:08:14 karltk Exp $
inherit java-pkg eutils
@@ -10,11 +10,16 @@ SRC_URI="http://cvs.apache.org/dist/jakarta/bsf/v2.3.0rc1/src/bsf-src-2.3.0.tar.
LICENSE="Apache-1.1"
SLOT="2.3"
KEYWORDS="~x86 ~ppc ~sparc"
-IUSE="doc jython rhino"
-DEPEND="jython? ( >=dev-java/jython-2.1-r5 )
+IUSE="doc jython rhino jikes"
+RDEPEND=">=virtual/jre-1.4
+ jython? ( >=dev-java/jython-2.1-r5 )
rhino? ( >=dev-java/rhino-1.4 )
=dev-java/servletapi-2.3*
>=dev-java/ant-1.5.4"
+DEPEND=">=virtual/jdk-1.4
+ jikes? ( >=dev-java/jikes-1.18 )
+ ${RDEPEND}"
+
src_unpack() {
unpack ${A}
@@ -29,26 +34,22 @@ src_unpack() {
if use jython; then
java-pkg_jar-from jython || die "Missing jython"
fi
+
}
src_compile() {
- # This ebuild is sensitive to the system classpath, so we need to start with a
- # pristine one.
- export CLASSPATH=
-
- local cp=$(java-config -p servletapi-2.3)
use rhino && cp="${cp}:$(java-config -p rhino)"
use jython && cp="${cp}:$(java-config -p jython)"
- local antflags=
-
# karltk: fix this
-# use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+
+ cd ${S}/src/taglib
+ ant ${antflags} -Dservlet.jar="$(java-config -p servletapi-2.3)" compile || die "Failed to build taglib"
- cd src
- export CLASSPATH=${cp}
- ant ${antflags} compile || die
+ cd ${S}/src
+ ant ${antflags} -Dclasspath=${cp} compile || die "Failed to build main package"
if use doc ; then
ant ${antflags} javadocs || die
fi