summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/irrlicht/ChangeLog5
-rw-r--r--dev-games/irrlicht/irrlicht-1.8-r2.ebuild8
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-games/irrlicht/ChangeLog b/dev-games/irrlicht/ChangeLog
index 2f3aa4b677e6..a194eaaaa294 100644
--- a/dev-games/irrlicht/ChangeLog
+++ b/dev-games/irrlicht/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-games/irrlicht
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.63 2013/03/06 18:47:08 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/ChangeLog,v 1.64 2013/03/07 17:15:43 hasufell Exp $
+
+ 07 Mar 2013; Julian Ospald <hasufell@gentoo.org> irrlicht-1.8-r2.ebuild:
+ add static-libs useflag wrt #460706
*irrlicht-1.8-r2 (06 Mar 2013)
diff --git a/dev-games/irrlicht/irrlicht-1.8-r2.ebuild b/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
index f7f993958837..29035df00937 100644
--- a/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
+++ b/dev-games/irrlicht/irrlicht-1.8-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8-r2.ebuild,v 1.1 2013/03/06 18:47:08 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/irrlicht/irrlicht-1.8-r2.ebuild,v 1.2 2013/03/07 17:15:43 hasufell Exp $
EAPI=5
inherit eutils multilib toolchain-funcs
@@ -12,7 +12,7 @@ SRC_URI="mirror://sourceforge/irrlicht/${P}.zip"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="debug doc"
+IUSE="debug doc static-libs"
RDEPEND="virtual/jpeg
media-libs/libpng:0
@@ -45,13 +45,13 @@ src_prepare() {
src_compile() {
tc-export CXX CC AR
- emake NDEBUG=$(usex debug "" "1") sharedlib staticlib
+ emake NDEBUG=$(usex debug "" "1") sharedlib $(usex static-libs "staticlib" "")
}
src_install() {
cd "${WORKDIR}"/${P} || die
- dolib.a lib/Linux/libIrrlicht.a
+ use static-libs && dolib.a lib/Linux/libIrrlicht.a
dolib.so lib/Linux/libIrrlicht.so*
# create library symlinks