summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/ode/ChangeLog10
-rw-r--r--dev-games/ode/files/digest-ode-0.5-r31
-rw-r--r--dev-games/ode/files/ode-0.5-PIC.patch2
-rw-r--r--dev-games/ode/ode-0.5-r3.ebuild69
4 files changed, 79 insertions, 3 deletions
diff --git a/dev-games/ode/ChangeLog b/dev-games/ode/ChangeLog
index d5e60cdcd0cd..180efab310ae 100644
--- a/dev-games/ode/ChangeLog
+++ b/dev-games/ode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-games/ode
-# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ChangeLog,v 1.14 2005/08/02 22:50:53 chrb Exp $
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ChangeLog,v 1.15 2005/10/30 21:19:35 vapier Exp $
+
+*ode-0.5-r3 (30 Oct 2005)
+
+ 30 Oct 2005; Mike Frysinger <vapier@gentoo.org> files/ode-0.5-PIC.patch,
+ +ode-0.5-r3.ebuild:
+ Fix paths to examples #110895 by Peter Koeleman.
02 Aug 2005; Chris Bainbridge <chrb@gentoo.org> ode-0.5-r2.ebuild:
Store user-settings file for later use by future versions of pyode.
diff --git a/dev-games/ode/files/digest-ode-0.5-r3 b/dev-games/ode/files/digest-ode-0.5-r3
new file mode 100644
index 000000000000..017c61381927
--- /dev/null
+++ b/dev-games/ode/files/digest-ode-0.5-r3
@@ -0,0 +1 @@
+MD5 b33b21e04ee9661f27802b6b6c8eefd2 ode-0.5.tgz 1710720
diff --git a/dev-games/ode/files/ode-0.5-PIC.patch b/dev-games/ode/files/ode-0.5-PIC.patch
index b3c1dcf9605c..01c2fcbeb8e4 100644
--- a/dev-games/ode/files/ode-0.5-PIC.patch
+++ b/dev-games/ode/files/ode-0.5-PIC.patch
@@ -11,8 +11,8 @@ http://bugs.gentoo.org/77079
+ "mov %%ebx,%%edi\n"
"mov $0,%%eax\n"
"cpuid\n"
-- : : : "%eax","%ebx","%ecx","%edx","cc","memory");
+ "mov %%edi,%%ebx\n"
+- : : : "%eax","%ebx","%ecx","%edx","cc","memory");
+ : : : "%eax","%edi","%ecx","%edx","cc","memory");
}
diff --git a/dev-games/ode/ode-0.5-r3.ebuild b/dev-games/ode/ode-0.5-r3.ebuild
new file mode 100644
index 000000000000..8954929a15a5
--- /dev/null
+++ b/dev-games/ode/ode-0.5-r3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/ode/ode-0.5-r3.ebuild,v 1.1 2005/10/30 21:19:35 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="Open Dynamics Engine SDK"
+HOMEPAGE="http://ode.org/"
+SRC_URI="mirror://sourceforge/opende/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc debug double-precision"
+
+DEPEND="virtual/x11
+ virtual/glu
+ virtual/opengl"
+
+config_use() {
+ use $1 && echo $2 || echo $3
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ echo 'C_FLAGS+=$(E_CFLAGS) -fPIC' >> config/makefile.unix-gcc
+ epatch "${FILESDIR}"/${P}-PIC.patch
+ sed -i -e "s/..\/..\/drawstuff\/textures/\/usr\/share\/${PF}\/examples/" ode/test/*.c*
+ sed -i -e "s/fn.path_to_textures = 0/fn.path_to_textures = \"\/usr\/share\/${PF}\/examples\"/" drawstuff/dstest/dstest.cpp
+ sed -i \
+ -e "s/#OPCODE_DIRECTORY/OPCODE_DIRECTORY/" \
+ -e "/^BUILD=/s:=.*:=$(config_use debug debug release):" \
+ -e "/^PRECISION=/s:=.*:=$(config_use double-precision DOUBLE SINGLE):" \
+ config/user-settings
+}
+
+src_compile() {
+ emake \
+ -j1 \
+ E_CFLAGS="${CFLAGS}" \
+ PLATFORM=unix-gcc \
+ || die "emake failed"
+}
+
+src_install() {
+ insinto /usr/include/ode
+ doins include/ode/*.h || die "doins failed"
+ dolib lib/libode.a lib/libdrawstuff.a || die "dolib failed"
+ dodir /usr/share/${P}/config
+ insinto /usr/share/${P}/config
+ doins config/user-settings
+ if use doc; then
+ dodoc README CHANGELOG ode/doc/ode.pdf
+ dohtml ode/doc/ode.html
+ dodir /usr/share/doc/${PF}/html/pix/
+ insinto /usr/share/doc/${PF}/html/pix/
+ doins ode/doc/pix/*.jpg
+ # install examples
+ dodir /usr/share/${PF}/examples
+ exeinto /usr/share/${PF}/examples
+ doexe ode/test/*.exe
+ doexe drawstuff/dstest/dstest.exe
+ insinto /usr/share/${PF}/examples
+ doins ode/test/*.c ode/test/*.cpp
+ doins drawstuff/textures/*.ppm
+ doins drawstuff/dstest/dstest.cpp
+ fi
+}