summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild')
-rw-r--r--dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild b/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild
deleted file mode 100644
index 4dade5c1f459..000000000000
--- a/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pnetlib/pnetlib-0.7.4.ebuild,v 1.12 2009/09/25 10:26:27 flameeyes Exp $
-
-inherit autotools eutils
-
-DESCRIPTION="Portable.NET C# library"
-HOMEPAGE="http://www.dotgnu.org/"
-SRC_URI="http://www.southern-storm.com.au/download/${P}.tar.gz"
-
-LICENSE="GPL-2-with-linking-exception"
-SLOT="0"
-KEYWORDS="amd64 arm hppa ia64 ppc x86"
-IUSE="doc truetype X"
-
-DEPEND="=dev-dotnet/pnet-${PV}*
- X? ( x11-libs/libSM
- x11-libs/libXft )
- truetype? ( x11-libs/libXft )
- =sys-devel/automake-1.4_p6"
-
-RDEPEND="=dev-dotnet/pnet-${PV}*
- X? ( x11-libs/libSM
- x11-libs/libXft )
- truetype? ( x11-libs/libXft )"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- # patch configure.in to detect renamed resgen.pnet ; bug #39369
- epatch "${FILESDIR}"/0.6.12-resgen.patch
-
- eautoreconf || die "eautoreconf failed"
-}
-
-src_compile() {
- local lib_profile="default1.1"
-
- elog "Using profile: ${lib_profile}"
- econf --with-profile=${lib_profile} \
- $(use_enable truetype xft) || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog HACKING NEWS README
-
- use doc && dodoc doc/*.txt
- use doc && dohtml doc/*.html
-}