summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog10
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch12
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch12
-rw-r--r--dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch49
-rw-r--r--dev-db/sqlite/sqlite-3.8.1.ebuild159
5 files changed, 241 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index e9fe78571c05..a5b3de49f20c 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.493 2013/09/06 18:36:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.494 2013/10/17 20:20:55 floppym Exp $
+
+*sqlite-3.8.1 (17 Oct 2013)
+
+ 17 Oct 2013; Mike Gilbert <floppym@gentoo.org>
+ +files/sqlite-3.8.1-autoconf-dlopen_check.patch,
+ +files/sqlite-3.8.1-src-dlopen_check.patch,
+ +files/sqlite-3.8.1-tests-icu-52.patch, +sqlite-3.8.1.ebuild:
+ Version bump. Ebuild and patches by Arfrever.
06 Sep 2013; Agostino Sarubbo <ago@gentoo.org> sqlite-3.7.17.ebuild:
Stable for sparc, wrt bug #479580
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch b/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch
new file mode 100644
index 000000000000..bd55a0778bd1
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.8.1-autoconf-dlopen_check.patch
@@ -0,0 +1,12 @@
+--- configure.ac
++++ configure.ac
+@@ -70,6 +70,9 @@
+ [], [enable_dynamic_extensions=yes])
+ if test x"$enable_dynamic_extensions" != "xno"; then
+ AC_SEARCH_LIBS(dlopen, dl)
++ if test "${ac_cv_search_dlopen}" = "no" ; then
++ DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
++ fi
+ else
+ DYNAMIC_EXTENSION_FLAGS=-DSQLITE_OMIT_LOAD_EXTENSION=1
+ fi
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch b/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch
new file mode 100644
index 000000000000..0c5b48d1db9a
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.8.1-src-dlopen_check.patch
@@ -0,0 +1,12 @@
+--- configure.ac
++++ configure.ac
+@@ -611,6 +611,9 @@
+ if test "${use_loadextension}" = "yes" ; then
+ OPT_FEATURE_FLAGS=""
+ AC_SEARCH_LIBS(dlopen, dl)
++ if test "${ac_cv_search_dlopen}" = "no" ; then
++ OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
++ fi
+ else
+ OPT_FEATURE_FLAGS="-DSQLITE_OMIT_LOAD_EXTENSION=1"
+ fi
diff --git a/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch b/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch
new file mode 100644
index 000000000000..c6cbb33c4918
--- /dev/null
+++ b/dev-db/sqlite/files/sqlite-3.8.1-tests-icu-52.patch
@@ -0,0 +1,49 @@
+--- test/fts4unicode.test
++++ test/fts4unicode.test
+@@ -366,27 +366,26 @@
+ do_isspace_test 6.$T.1 $T 32
+ do_isspace_test 6.$T.2 $T 160
+ do_isspace_test 6.$T.3 $T 5760
+- do_isspace_test 6.$T.4 $T 6158
+- do_isspace_test 6.$T.5 $T 8192
+- do_isspace_test 6.$T.6 $T 8193
+- do_isspace_test 6.$T.7 $T 8194
+- do_isspace_test 6.$T.8 $T 8195
+- do_isspace_test 6.$T.9 $T 8196
+- do_isspace_test 6.$T.10 $T 8197
+- do_isspace_test 6.$T.11 $T 8198
+- do_isspace_test 6.$T.12 $T 8199
+- do_isspace_test 6.$T.13 $T 8200
+- do_isspace_test 6.$T.14 $T 8201
+- do_isspace_test 6.$T.15 $T 8202
+- do_isspace_test 6.$T.16 $T 8239
+- do_isspace_test 6.$T.17 $T 8287
+- do_isspace_test 6.$T.18 $T 12288
++ do_isspace_test 6.$T.4 $T 8192
++ do_isspace_test 6.$T.5 $T 8193
++ do_isspace_test 6.$T.6 $T 8194
++ do_isspace_test 6.$T.7 $T 8195
++ do_isspace_test 6.$T.8 $T 8196
++ do_isspace_test 6.$T.9 $T 8197
++ do_isspace_test 6.$T.10 $T 8198
++ do_isspace_test 6.$T.11 $T 8199
++ do_isspace_test 6.$T.12 $T 8200
++ do_isspace_test 6.$T.13 $T 8201
++ do_isspace_test 6.$T.14 $T 8202
++ do_isspace_test 6.$T.15 $T 8239
++ do_isspace_test 6.$T.16 $T 8287
++ do_isspace_test 6.$T.17 $T 12288
+
+- do_isspace_test 6.$T.19 $T {32 160 5760 6158}
+- do_isspace_test 6.$T.20 $T {8192 8193 8194 8195}
+- do_isspace_test 6.$T.21 $T {8196 8197 8198 8199}
+- do_isspace_test 6.$T.22 $T {8200 8201 8202 8239}
+- do_isspace_test 6.$T.23 $T {8287 12288}
++ do_isspace_test 6.$T.18 $T {32 160 5760}
++ do_isspace_test 6.$T.19 $T {8192 8193 8194 8195}
++ do_isspace_test 6.$T.20 $T {8196 8197 8198 8199}
++ do_isspace_test 6.$T.21 $T {8200 8201 8202 8239}
++ do_isspace_test 6.$T.22 $T {8287 12288}
+ }
+
+ #-------------------------------------------------------------------------
diff --git a/dev-db/sqlite/sqlite-3.8.1.ebuild b/dev-db/sqlite/sqlite-3.8.1.ebuild
new file mode 100644
index 000000000000..982851a0a707
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.8.1.ebuild
@@ -0,0 +1,159 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.8.1.ebuild,v 1.1 2013/10/17 20:20:55 floppym Exp $
+
+EAPI="5"
+
+inherit autotools eutils flag-o-matic multilib versionator
+
+SRC_PV="$(printf "%u%02u%02u%02u" $(get_version_components))"
+DOC_PV="${SRC_PV}"
+# DOC_PV="$(printf "%u%02u%02u00" $(get_version_components $(get_version_component_range 1-3)))"
+
+DESCRIPTION="A SQL Database Engine in a C Library"
+HOMEPAGE="http://sqlite.org/"
+SRC_URI="doc? ( http://sqlite.org/2013/${PN}-doc-${DOC_PV}.zip )
+ tcl? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
+ !tcl? (
+ test? ( http://sqlite.org/2013/${PN}-src-${SRC_PV}.zip )
+ !test? ( http://sqlite.org/2013/${PN}-autoconf-${SRC_PV}.tar.gz )
+ )"
+
+LICENSE="public-domain"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug doc icu +readline secure-delete static-libs tcl test"
+
+RDEPEND="icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline )
+ tcl? ( dev-lang/tcl:= )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )
+ tcl? ( app-arch/unzip )
+ test? (
+ app-arch/unzip
+ dev-lang/tcl
+ )"
+
+amalgamation() {
+ use !tcl && use !test
+}
+
+pkg_setup() {
+ if amalgamation; then
+ S="${WORKDIR}/${PN}-autoconf-${SRC_PV}"
+ else
+ S="${WORKDIR}/${PN}-src-${SRC_PV}"
+ fi
+}
+
+src_prepare() {
+ if amalgamation; then
+ epatch "${FILESDIR}/${P}-autoconf-dlopen_check.patch"
+ else
+ epatch "${FILESDIR}/${P}-src-dlopen_check.patch"
+ epatch "${FILESDIR}/${P}-tests-icu-52.patch"
+ fi
+
+ eautoreconf
+
+ # At least ppc-aix, x86-interix and *-solaris need newer libtool.
+ # use prefix && eautoreconf
+}
+
+src_configure() {
+ # `configure` from amalgamation tarball does not add -DSQLITE_DEBUG or -DNDEBUG flag.
+ if amalgamation; then
+ if use debug; then
+ append-cppflags -DSQLITE_DEBUG
+ else
+ append-cppflags -DNDEBUG
+ fi
+ fi
+
+ # Support column metadata functions.
+ # http://sqlite.org/c3ref/column_database_name.html
+ # http://sqlite.org/c3ref/table_column_metadata.html
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+ # Support Full-Text Search versions 3 and 4.
+ # http://sqlite.org/fts3.html
+ append-cppflags -DSQLITE_ENABLE_FTS3 -DSQLITE_ENABLE_FTS3_PARENTHESIS -DSQLITE_ENABLE_FTS4 -DSQLITE_ENABLE_FTS4_UNICODE61
+
+ # Support R*Trees.
+ # http://sqlite.org/rtree.html
+ append-cppflags -DSQLITE_ENABLE_RTREE
+
+ # Support soundex() function.
+ # http://sqlite.org/lang_corefunc.html#soundex
+ append-cppflags -DSQLITE_SOUNDEX
+
+ # Support unlock notification.
+ # http://sqlite.org/unlock_notify.html
+ append-cppflags -DSQLITE_ENABLE_UNLOCK_NOTIFY
+
+ if use icu; then
+ append-cppflags -DSQLITE_ENABLE_ICU
+ if amalgamation; then
+ sed -e "s/LIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
+ else
+ sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
+ fi
+ fi
+
+ # Enable secure_delete pragma.
+ # http://sqlite.org/pragma.html#pragma_secure_delete
+ if use secure-delete; then
+ append-cppflags -DSQLITE_SECURE_DELETE -DSQLITE_CHECK_PAGES -DSQLITE_CORE
+ fi
+
+ # Starting from 3.6.23, SQLite has locking strategies that are specific to
+ # OSX. By default they are enabled, and use semantics that only make sense
+ # on OSX. However, they require gethostuuid() function for that, which is
+ # only available on OSX starting from 10.6 (Snow Leopard). For earlier
+ # versions of OSX we have to disable all this nifty locking options, as
+ # suggested by upstream.
+ if [[ "${CHOST}" == *-darwin[56789] ]]; then
+ append-cppflags -DSQLITE_ENABLE_LOCKING_STYLE="0"
+ fi
+
+ if [[ "${CHOST}" == *-mint* ]]; then
+ append-cppflags -DSQLITE_OMIT_WAL
+ fi
+
+ # `configure` from amalgamation tarball does not support
+ # --with-readline-inc and --(enable|disable)-tcl options.
+ econf \
+ --enable-$(amalgamation && echo dynamic-extensions || echo load-extension) \
+ --enable-threadsafe \
+ $(use_enable readline) \
+ $(use_enable static-libs static) \
+ $(amalgamation || echo --with-readline-inc="-I${EPREFIX}/usr/include/readline") \
+ $(amalgamation || use_enable debug) \
+ $(amalgamation || echo --enable-tcl)
+}
+
+src_compile() {
+ emake TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}"
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions"
+ return
+ fi
+
+ emake $(use debug && echo fulltest || echo test)
+}
+
+src_install() {
+ emake DESTDIR="${D}" HAVE_TCL="$(usex tcl 1 "")" TCLLIBDIR="${EPREFIX}/usr/$(get_libdir)/${P}" install
+ prune_libtool_files
+
+ doman sqlite3.1
+
+ if use doc; then
+ find "${WORKDIR}/${PN}-doc-${DOC_PV}" -name ".[_~]*" -delete
+ dohtml -A ico,odg,pdf,svg -r "${WORKDIR}/${PN}-doc-${DOC_PV}/"
+ fi
+}