summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql/postgresql-8.0.3.ebuild')
-rw-r--r--dev-db/postgresql/postgresql-8.0.3.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/dev-db/postgresql/postgresql-8.0.3.ebuild b/dev-db/postgresql/postgresql-8.0.3.ebuild
index b1bff4d05333..6887abe72d9e 100644
--- a/dev-db/postgresql/postgresql-8.0.3.ebuild
+++ b/dev-db/postgresql/postgresql-8.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.3.ebuild,v 1.1 2005/05/16 06:54:44 nakano Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.3.ebuild,v 1.1.1.1 2005/11/30 10:11:43 chriswhite Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -16,12 +16,12 @@ SRC_URI="mirror://postgresql/source/v${PV}/${PN}-base-${MY_PV}.tar.bz2
LICENSE="POSTGRESQL"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~arm ~hppa ~amd64 ~ia64 ~s390 ~ppc64"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
IUSE="ssl nls python tcltk perl libg++ pam readline xml2 zlib doc selinux kerberos pg-intdatetime pg-hier"
S=${WORKDIR}/${MY_P}
DEPEND="virtual/libc
- =dev-db/libpq-8.0.3
+ =dev-db/libpq-8.0.3*
sys-devel/autoconf
>=sys-libs/ncurses-5.2
>=sys-devel/bison-1.875
@@ -35,7 +35,7 @@ DEPEND="virtual/libc
nls? ( sys-devel/gettext )
kerberos? ( virtual/krb5 )"
RDEPEND="virtual/libc
- =dev-db/libpq-8.0.3
+ =dev-db/libpq-8.0.3*
zlib? ( >=sys-libs/zlib-1.1.3 )
tcltk? ( >=dev-lang/tcl-8 )
perl? ( >=dev-lang/perl-5.6.1-r2 )
@@ -67,6 +67,7 @@ src_unpack() {
cd ${S}
use pg-hier && epatch ${WORKDIR}/${P_HIERPG}.diff
epatch ${FILESDIR}/${P}-gentoo.patch
+ epatch ${FILESDIR}/${P}-sh.patch
}
src_compile() {
@@ -99,7 +100,6 @@ src_compile() {
--with-docdir=/usr/share/doc/${PF} \
--libdir=/usr/$(get_libdir) \
--enable-depend \
- --with-gnu-ld \
$myconf || die
make LD="$(tc-getLD) $(get_abi_LDFLAGS)" || die
@@ -168,7 +168,7 @@ pkg_postinst() {
if [ ! -f ${PG_DIR}/data/PG_VERSION ] ; then
einfo ""
einfo "Execute the following command"
- einfo "ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo "emerge --config =${PF}"
einfo "to setup the initial database environment."
einfo ""
fi