summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/postgresql-base/postgresql-base-9999.ebuild')
-rw-r--r--dev-db/postgresql-base/postgresql-base-9999.ebuild59
1 files changed, 24 insertions, 35 deletions
diff --git a/dev-db/postgresql-base/postgresql-base-9999.ebuild b/dev-db/postgresql-base/postgresql-base-9999.ebuild
index 19ebbe8b7455..7963416c4a43 100644
--- a/dev-db/postgresql-base/postgresql-base-9999.ebuild
+++ b/dev-db/postgresql-base/postgresql-base-9999.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-9999.ebuild,v 1.8 2013/08/14 09:28:16 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-base/postgresql-base-9999.ebuild,v 1.9 2013/09/15 21:15:12 titanofold Exp $
-EAPI="4"
+EAPI="5"
+PYTHON_COMPAT=( python{2_{5,6,7},3_{1,2,3}} )
WANT_AUTOMAKE="none"
-inherit autotools eutils flag-o-matic multilib prefix versionator base git-2
+inherit autotools eutils flag-o-matic multilib prefix python-single-r1 versionator base git-2
KEYWORDS=""
@@ -16,18 +17,6 @@ SLOT="9.4"
EGIT_REPO_URI="git://git.postgresql.org/git/postgresql.git"
SRC_URI="http://dev.gentoo.org/~titanofold/postgresql-patches-9.3-r1.tbz2"
-# Comment the following five lines when not a beta or rc.
-#MY_PV="${PV//_}"
-#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
-#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
-#SRC_URI="mirror://postgresql/source/v${MY_PV}/postgresql-${MY_FILE_PV}.tar.bz2
-# http://dev.gentoo.org/~titanofold/postgresql-patches-${MY_FILE_PV}.tbz2"
-
-# Comment the following three lines when a beta or rc.
-#S="${WORKDIR}/postgresql-${PV}"
-#SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2
-# http://dev.gentoo.org/~titanofold/postgresql-patches-${PV}.tbz2"
-
LICENSE="POSTGRESQL"
DESCRIPTION="PostgreSQL libraries and clients"
HOMEPAGE="http://www.postgresql.org/"
@@ -36,7 +25,7 @@ HOMEPAGE="http://www.postgresql.org/"
RESTRICT="test"
LINGUAS="af cs de en es fa fr hr hu it ko nb pl pt_BR ro ru sk sl sv tr zh_CN zh_TW"
-IUSE="doc kerberos ldap nls pam pg_legacytimestamp readline ssl threads zlib"
+IUSE="doc kerberos ldap nls pam pg_legacytimestamp python readline ssl threads zlib"
for lingua in ${LINGUAS} ; do
IUSE+=" linguas_${lingua}"
@@ -52,29 +41,29 @@ wanted_languages() {
echo -n ${enable_langs}
}
-RDEPEND="!!dev-db/libpq
- !!dev-db/postgresql
- !!dev-db/postgresql-client
- !!dev-db/postgresql-libs
- sys-apps/less
- >=app-admin/eselect-postgresql-1.0.10
- virtual/libintl
- kerberos? ( virtual/krb5 )
- ldap? ( net-nds/openldap )
- pam? ( virtual/pam )
- readline? ( sys-libs/readline )
- ssl? ( >=dev-libs/openssl-0.9.6-r1 )
- zlib? ( sys-libs/zlib )
+RDEPEND="
+>=app-admin/eselect-postgresql-1.2.0
+sys-apps/less
+virtual/libintl
+kerberos? ( virtual/krb5 )
+ldap? ( net-nds/openldap )
+pam? ( virtual/pam )
+python? ( ${PYTHON_DEPS} )
+readline? ( sys-libs/readline )
+ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+zlib? ( sys-libs/zlib )
"
DEPEND="${RDEPEND}
- !!<sys-apps/sandbox-2.0
- sys-devel/bison
- sys-devel/flex
- nls? ( sys-devel/gettext )
+!!<sys-apps/sandbox-2.0
+sys-devel/bison
+sys-devel/flex
+nls? ( sys-devel/gettext )
"
-#PDEPEND="doc? ( ~dev-db/postgresql-docs-${PV} )"
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
src_unpack() {
base_src_unpack
@@ -130,13 +119,13 @@ src_configure() {
--mandir="${PO}/usr/share/postgresql-${SLOT}/man" \
--without-tcl \
--without-perl \
- --without-python \
$(use_with readline) \
$(use_with kerberos krb5) \
$(use_with kerberos gssapi) \
"$(use_enable nls nls "$(wanted_languages)")" \
$(use_with pam) \
$(use_enable !pg_legacytimestamp integer-datetimes) \
+ $(use_with python) \
$(use_with ssl openssl) \
$(use_enable threads thread-safety) \
$(use_with zlib) \