summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgbouncer')
-rw-r--r--dev-db/pgbouncer/ChangeLog9
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.5.ebuild71
2 files changed, 78 insertions, 2 deletions
diff --git a/dev-db/pgbouncer/ChangeLog b/dev-db/pgbouncer/ChangeLog
index 6291bd0f0c20..1a61e8424d0a 100644
--- a/dev-db/pgbouncer/ChangeLog
+++ b/dev-db/pgbouncer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgbouncer
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.1 2011/11/16 04:17:36 titanofold Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.2 2012/03/29 02:16:04 titanofold Exp $
+
+*pgbouncer-1.5 (29 Mar 2012)
+
+ 29 Mar 2012; Aaron W. Swenson <titanofold@gentoo.org> +pgbouncer-1.5.ebuild:
+ Version bump. Fixes bug 405225.
*pgbouncer-1.4.2 (16 Nov 2011)
diff --git a/dev-db/pgbouncer/pgbouncer-1.5.ebuild b/dev-db/pgbouncer/pgbouncer-1.5.ebuild
new file mode 100644
index 000000000000..a87da03dbc6a
--- /dev/null
+++ b/dev-db/pgbouncer/pgbouncer-1.5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/pgbouncer-1.5.ebuild,v 1.1 2012/03/29 02:16:02 titanofold Exp $
+
+EAPI="4"
+
+inherit eutils
+
+RESTRICT="test"
+
+DESCRIPTION="Lightweight connection pooler for PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/pgbouncer/"
+SRC_URI="mirror://postgresql/projects/pgFoundry/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup pgbouncer
+ enewuser pgbouncer -1 -1 -1 pgbouncer
+}
+
+src_prepare() {
+ local rundir=""
+ [[ ! -d /run ]] && rundir="/var"
+
+ sed -i -e "s,${PN}.log,/var/log/${PN}/${PN}.log," \
+ -e "s,${PN}.pid,/var/run/${PN}/${PN}.pid," \
+ -e "s,etc/userlist.txt,/etc/userlist.txt," \
+ -e "s,;unix_socket_dir = /tmp,unix_socket_dir = ${rundir}/run/${PN}.sock," \
+ "${S}"/etc/pgbouncer.ini || die
+}
+
+src_configure() {
+ # --enable-debug is only used to disable stripping
+ econf \
+ --enable-debug \
+ $(use_enable debug cassert) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ newins etc/pgbouncer.ini pgbouncer.conf
+ newinitd "${FILESDIR}"/pgbouncer.initd "${PN}"
+
+ dodoc README NEWS AUTHORS
+ dodoc doc/*.txt
+
+ dodir /var/log/pgbouncer/
+ fowners pgbouncer:pgbouncer /var/log/pgbouncer/
+}
+
+pkg_postinst() {
+ einfo "Please read the config.txt for Configuration Directives"
+ einfo
+ einfo "For Administration Commands, see:"
+ einfo " man pgbouncer"
+ einfo
+ einfo "By default, PgBouncer does not have access to any database."
+ einfo "GRANT the permissions needed for your application and make sure that it"
+ einfo "exists in PgBouncer's auth_file."
+
+}