summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql')
-rw-r--r--dev-db/mysql/ChangeLog12
-rw-r--r--dev-db/mysql/Manifest10
-rw-r--r--dev-db/mysql/files/digest-mysql-4.1.141
-rw-r--r--dev-db/mysql/mysql-3.23.58-r1.ebuild4
-rw-r--r--dev-db/mysql/mysql-4.0.26.ebuild149
-rw-r--r--dev-db/mysql/mysql-4.1.14.ebuild336
-rw-r--r--dev-db/mysql/mysql-5.0.12_beta.ebuild158
7 files changed, 356 insertions, 314 deletions
diff --git a/dev-db/mysql/ChangeLog b/dev-db/mysql/ChangeLog
index e3745571a5ed..7b2624e055eb 100644
--- a/dev-db/mysql/ChangeLog
+++ b/dev-db/mysql/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-db/mysql
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.228 2005/09/08 14:57:21 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/ChangeLog,v 1.229 2005/09/09 11:42:28 vivo Exp $
+
+ 09 Sep 2005; Francesco Riosa <vivo@gentoo.org> mysql-4.0.26.ebuild,
+ mysql-4.1.14.ebuild, mysql-5.0.12_beta.ebuild:
+ - Added "MYSQL_STRAIGHT_UPGRADE" to MySQL 4.1 ebuilds, this permit to upgrade
+ plainly from 4.0 series. A similar patch for 5.0 will follow.
+ - Uniformation of mysql-4.1 ebuild to the 5.1 series one, now diff -Naur of the
+ two should be smaller
+ - fix for Bug #103975 dev-db/mysql shouldn't use enewuser and enewgroup in
+ src_install() The bug was introduced when fixing bug #95320.
+ - also mysql-4.1 now downloads mysql-extras-*.tar.bz2 from gentoo mirrors.
*mysql-4.0.26 (08 Sep 2005)
diff --git a/dev-db/mysql/Manifest b/dev-db/mysql/Manifest
index 886409cc57f5..2228a5928af6 100644
--- a/dev-db/mysql/Manifest
+++ b/dev-db/mysql/Manifest
@@ -1,12 +1,12 @@
-MD5 7917cccbcb071ac4bc0c19d2d14b7f5c mysql-5.0.12_beta.ebuild 17120
-MD5 26109dc9429cc2fb578813e3dc04bc79 mysql-4.1.14.ebuild 16330
-MD5 5a9c127d5a5ee1f2d6f48a0fb5a209a6 mysql-4.0.26.ebuild 13448
+MD5 290d3a417ed0c5afaceebbd216f91bf3 mysql-5.0.12_beta.ebuild 16820
+MD5 60d0e06000f5be37902282e74f4c4ada mysql-4.1.14.ebuild 16593
+MD5 5161775be316600608d991b866982a56 mysql-4.0.26.ebuild 13310
MD5 0dfa3f1c8accfc384b42caf169f8948c mysql-4.1.13-r1.ebuild 16277
MD5 d168c71df57729ea0eeadab3c6a59f43 mysql-4.0.22.ebuild 8768
MD5 c28056421db550a09a548ad1dff517f5 mysql-4.0.22-r2.ebuild 9613
-MD5 82eebc79341497bc468d529ecac22ab1 mysql-3.23.58-r1.ebuild 7064
+MD5 c9e0dc9f8694b4531f846e6eb9de3f11 mysql-3.23.58-r1.ebuild 7063
MD5 240fc6da2d2c2d7dd224b147db251f80 mysql-4.0.24.ebuild 9827
-MD5 70144ffcd3539d54f1d7506fc94648c4 ChangeLog 39691
+MD5 cc9cf93639b1641bcef4c8a1af5c513c ChangeLog 40278
MD5 a2a9fdc7d010a7c04c96cb3b7c05f06b metadata.xml 158
MD5 630544f322676eaca90b99f8d7e6aaf3 mysql-4.0.25-r2.ebuild 13770
MD5 a755fb5a3ed724046a4f83fafd819c77 files/mysql-test-myisam-geometry.patch 1217
diff --git a/dev-db/mysql/files/digest-mysql-4.1.14 b/dev-db/mysql/files/digest-mysql-4.1.14
index d30c902ffc6e..6bad0e94a5d6 100644
--- a/dev-db/mysql/files/digest-mysql-4.1.14
+++ b/dev-db/mysql/files/digest-mysql-4.1.14
@@ -1 +1,2 @@
MD5 98ba9caea24b0a48ee06bb242ff2e37f mysql-4.1.14.tar.gz 17074439
+MD5 adaf3f0e5174f968bef0f910aff65f7d mysql-extras-20050908.tar.bz2 46663
diff --git a/dev-db/mysql/mysql-3.23.58-r1.ebuild b/dev-db/mysql/mysql-3.23.58-r1.ebuild
index b6afc44784d1..46551975c338 100644
--- a/dev-db/mysql/mysql-3.23.58-r1.ebuild
+++ b/dev-db/mysql/mysql-3.23.58-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58-r1.ebuild,v 1.15 2005/07/27 00:22:45 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-3.23.58-r1.ebuild,v 1.16 2005/09/09 11:42:28 vivo Exp $
inherit flag-o-matic eutils
@@ -63,7 +63,7 @@ src_compile() {
replace-cpu-flags k6 k6-2 k6-3 i586
local myconf
- # The following fix is due to a bug with bdb on sparc's. See:
+ # The following fix is due to a bug with bdb on sparc's. See:
# http://www.geocrawler.com/mail/msg.php3?msg_id=4754814&list=8
# same for alpha (see http://www.mysql.com/doc/en/BDB_portability.html)
# thanks to peter@icebear.net for noticing this.
diff --git a/dev-db/mysql/mysql-4.0.26.ebuild b/dev-db/mysql/mysql-4.0.26.ebuild
index f3fb20b13479..f598040e7950 100644
--- a/dev-db/mysql/mysql-4.0.26.ebuild
+++ b/dev-db/mysql/mysql-4.0.26.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.1 2005/09/08 14:57:22 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.0.26.ebuild,v 1.2 2005/09/09 11:42:28 vivo Exp $
inherit eutils gnuconfig flag-o-matic versionator
@@ -37,6 +37,17 @@ RDEPEND="${DEPEND}
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
PDEPEND="perl? ( dev-perl/DBD-mysql )"
+mysql_upgrade_warning() {
+ ewarn
+ ewarn "If you're upgrading from MySQL-3.x to 4.0, or 4.0.x to 4.1.x, you"
+ ewarn "must recompile the other packages on your system that link with"
+ ewarn "libmysqlclient after the upgrade completes. To obtain such a list"
+ ewarn "of packages for your system, you may use 'revdep-rebuild' from"
+ ewarn "app-portage/gentoolkit."
+ ewarn
+ epause 5
+}
+
mysql_get_datadir() {
DATADIR=""
if [ -f '/etc/mysql/my.cnf' ] ; then
@@ -53,20 +64,14 @@ mysql_get_datadir() {
export DATADIR
}
-mysql_upgrade_warning() {
- ewarn
- ewarn "If you're upgrading from MySQL-3.x to 4.0, or 4.0.x to 4.1.x, you"
- ewarn "must recompile the other packages on your system that link with"
- ewarn "libmysqlclient after the upgrade completes. To obtain such a list"
- ewarn "of packages for your system, you may use 'revdep-rebuild' from"
- ewarn "app-portage/gentoolkit."
- ewarn
- epause 5
-}
-
pkg_setup() {
mysql_upgrade_warning
mysql_get_datadir
+
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+
}
src_unpack() {
@@ -222,23 +227,32 @@ src_compile() {
emake || die "compile problem"
}
-src_install() {
- make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
-
- enewgroup mysql 60 || die "problem adding group mysql"
- enewuser mysql 60 -1 /dev/null mysql \
- || die "problem adding user mysql"
+src_test() {
+ cd ${S}
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq minimal; then
+ local retstatus
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ addpredict /this-dir-does-not-exist/t9.MYI
+ make test
+ retstatus=$?
- diropts "-m0750"
- dodir "${DATADIR}" /var/log/mysql
+ # to be sure ;)
+ pkill -9 -f ${S}/ndb/src/kernel/ndbd 2>/dev/null
+ pkill -9 -f ${S}/ndb/src/mgmsrv/ndb_mgmd 2>/dev/null
+ pkill -9 -f ${S}/ndb/src/mgmclient/ndb_mgm 2>/dev/null
+ pkill -9 -f ${S}/sql/mysqld 2>/dev/null
+ [[ $retstatus == 0 ]] || die "make test failed"
- diropts "-m0755"
- dodir /var/run/mysqld
+ else
+ einfo "Skipping server tests due to minimal build."
+ fi
+}
- keepdir "${DATADIR}" /var/run/mysqld /var/log/mysql
- chown -R mysql:mysql ${D}/${DATADIR} \
- ${D}/var/run/mysqld \
- ${D}/var/log/mysql
+src_install() {
+ mysql_get_datadir
+ make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
# move client libs, install a couple of missing headers
local lib=$(get_libdir)
@@ -291,6 +305,26 @@ src_install() {
newexe "${FILESDIR}/mysql-4.0.24-r2.rc6" mysql
insinto /etc/logrotate.d
newins "${FILESDIR}/logrotate.mysql" mysql
+
+ #empty dirs...
+ diropts "-m0750"
+ if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
+ dodir "${DATADIR}"
+ keepdir "${DATADIR}"
+ chown -R mysql:mysql "${D}/${DATADIR}"
+ fi
+
+ dodir "/var/log/mysql"
+ touch ${D}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${D}/var/log/mysql/mysql.{log,err}
+
+ diropts "-m0755"
+ dodir "/var/run/mysqld"
+
+ keepdir "/var/run/mysqld" "${D}/var/log/mysql"
+ chown -R mysql:mysql \
+ "${D}/var/run/mysqld" \
+ "${D}/var/log/mysql"
fi
# docs
@@ -305,27 +339,26 @@ src_install() {
}
-src_test() {
- cd ${S}
- einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
- make check || die "make check failed"
- if ! useq minimal; then
- local retstatus
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- addpredict /this-dir-does-not-exist/t9.MYI
- make test
- retstatus=$?
+pkg_preinst() {
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+}
- # to be sure ;)
- pkill -9 -f ${S}/ndb/src/kernel/ndbd 2>/dev/null
- pkill -9 -f ${S}/ndb/src/mgmsrv/ndb_mgmd 2>/dev/null
- pkill -9 -f ${S}/ndb/src/mgmclient/ndb_mgm 2>/dev/null
- pkill -9 -f ${S}/sql/mysqld 2>/dev/null
- [[ $retstatus == 0 ]] || die "make test failed"
+pkg_postinst() {
+ mysql_get_datadir
- else
- einfo "Skipping server tests due to minimal build."
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
}
pkg_config() {
@@ -405,31 +438,3 @@ pkg_config() {
einfo "done"
}
-
-pkg_postinst() {
- mysql_get_datadir
-
- if ! useq minimal; then
- #empty dirs...
- [ -d "${ROOT}/${DATADIR}" ] || install -d -m0750 -o mysql -g mysql ${ROOT}/var/lib/mysql
- [ -d "${ROOT}/var/run/mysqld" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
- [ -d "${ROOT}/var/log/mysql" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- # secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql ${ROOT}/${DATADIR}
-
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
- einfo "if this is a new install."
- einfo
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}
diff --git a/dev-db/mysql/mysql-4.1.14.ebuild b/dev-db/mysql/mysql-4.1.14.ebuild
index f6c3456a0c68..b558d0d0185d 100644
--- a/dev-db/mysql/mysql-4.1.14.ebuild
+++ b/dev-db/mysql/mysql-4.1.14.ebuild
@@ -1,12 +1,13 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.1 2005/08/29 12:55:19 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-4.1.14.ebuild,v 1.2 2005/09/09 11:42:28 vivo Exp $
-inherit eutils gnuconfig flag-o-matic versionator
+inherit eutils flag-o-matic versionator
SVER=${PV%.*}
-PLV=""
-NEWP="${PN}-${SVER}.$( get_version_component_range 3-3 )${PLV}"
+NEWP="${PN}-${PV}"
+#NEWP="${NEWP/_beta/-beta}"
+
# shorten the path because the socket path length must be shorter than 107 chars
# and we will run a mysql server during test phase
@@ -14,27 +15,32 @@ S="${WORKDIR}/${PN}"
DESCRIPTION="A fast, multi-threaded, multi-user SQL database server"
HOMEPAGE="http://www.mysql.com/"
-SRC_URI="mirror://mysql/Downloads/MySQL-${SVER}/${NEWP}.tar.gz"
+SRC_URI="mirror://mysql/Downloads/MySQL-${SVER}/${NEWP}.tar.gz
+ mirror://gentoo/mysql-extras-20050908.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~sparc ~ia64 ~ppc ~ppc64"
-IUSE="berkdb debug doc minimal perl readline selinux ssl static tcpd cluster utf8 geometry extraengine big-tables"
+IUSE="big-tables berkdb debug doc minimal perl readline selinux ssl static tcpd"
RESTRICT="primaryuri"
DEPEND="readline? ( >=sys-libs/readline-4.1 )
- bdb? ( sys-apps/ed )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6-r6 )
- ssl? ( >=dev-libs/openssl-0.9.6d )
- perl? ( dev-lang/perl )
- >=sys-libs/zlib-1.2.3
- >=sys-apps/texinfo-4.7-r1
- sys-process/procps
- >=sys-apps/sed-4"
+ bdb? ( sys-apps/ed )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6-r6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ perl? ( dev-lang/perl )
+ >=sys-libs/zlib-1.2.3
+ >=sys-apps/texinfo-4.7-r1
+ sys-process/procps
+ >=sys-apps/sed-4"
RDEPEND="${DEPEND} selinux? ( sec-policy/selinux-mysql )"
# dev-perl/DBD-mysql is needed by some scripts installed by MySQL
PDEPEND="perl? ( >=dev-perl/DBD-mysql-2.9004 )"
+if version_is_at_least "4.1.3" ; then
+ IUSE="${IUSE} cluster utf8 geometry extraengine"
+fi
+
mysql_upgrade_error() {
mysql_get_datadir
ewarn "Sorry plain upgrade from version of MySQL before 4.1.4 is NOT supported."
@@ -90,26 +96,37 @@ mysql_get_datadir() {
}
pkg_setup() {
- mysql_get_datadir
- if ! useq minimal ; then
- if has_version "<=dev-db/mysql-4.1.4" \
- && ! built_with_use dev-db/mysql minimal \
- && [ -d "${DATADIR}/mysql" ]; then
- mysql_upgrade_error
- die
+ if [[ -z $MYSQL_STRAIGHT_UPGRADE ]] ; then
+ mysql_get_datadir
+ if ! useq minimal && version_is_at_least "4.1.4"; then
+ if has_version "<=dev-db/mysql-4.1.4" \
+ && ! built_with_use dev-db/mysql minimal \
+ && [ -d "${DATADIR}/mysql" ]; then
+ mysql_upgrade_error
+ die "plain upgrade unsupported, export MYSQL_STRAIGHT_UPGRADE=1 to force upgrade"
+ fi
fi
fi
mysql_upgrade_warning
+
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+
}
src_unpack() {
- if use static && use ssl; then
+ if useq static && useq ssl; then
local msg="MySQL does not support building statically with SSL support"
eerror "${msg}"
die "${msg}"
fi
- if useq cluster || useq geometry || useq extraengine && useq minimal; then
+ if version_is_at_least "4.1.3" \
+ && useq cluster \
+ || useq geometry \
+ || useq extraengine \
+ && useq minimal ; then
die "USEs cluster, geometry, extraengine conflicts with \"minimal\""
fi
@@ -117,27 +134,14 @@ src_unpack() {
mv "${WORKDIR}/${NEWP}" "${S}"
cd "${S}"
+ rm -rf "${S}/zlib"
+ sed -i -e "s/zlib\/Makefile dnl/dnl zlib\/Makefile/" "${S}/configure.in"
- # for correct hardcoded sysconf directory
- epatch "${FILESDIR}/${PN}-4.0-my-print-defaults.diff"
-
- # attempt to get libmysqlclient_r linked against ssl if USE="ssl" enabled
- # i would really prefer to fix this at the Makefile.am level, but can't
- # get the software to autoreconf as distributed - too many missing files
- epatch "${FILESDIR}/${PN}-4.1.9-thrssl.patch"
+ local MY_PATCH_SOURCE="${WORKDIR}/mysql-extras"
- # FIXED upstrem in 4.1.14
- # PIC fixes
- # bug #42968
- #epatch "${FILESDIR}/035_x86_asm-pic-fixes-r3.patch"
-
- if use tcpd; then
- epatch "${FILESDIR}/${PN}-4.0.14-r1-tcpd-vars-fix.diff"
- fi
-
- # FIXED upstrem in 4.1.14
- # avoid error running src_test and not enabling geometry USE flag
- #useq geometry || epatch "${FILESDIR}/${PN}-test-myisam-geometry.patch"
+ epatch ${MY_PATCH_SOURCE}/010_all_my-print-defaults-r0.patch || die
+ epatch ${MY_PATCH_SOURCE}/030_all_thrssl-r1.patch || die
+ epatch ${MY_PATCH_SOURCE}/040_all_tcpd-vars-fix.patch || die
for d in ${S} ${S}/innobase; do
cd ${d}
@@ -152,14 +156,6 @@ src_unpack() {
gnuconfig_update
done
- ## Should be fixed in 4.1.12
- # upstream bug http://bugs.mysql.com/bug.php?id=7971
- # names conflict with stuff in 2.6.10 kernel headers
- #sed -i.orig \
- # -e "s/\<set_bit\>/my__set_bit/g" \
- # -e "s/\<clear_bit\>/my__clear_bit/g" \
- # ${S}/client/mysqltest.c || die "Failed to fix bitops"
-
}
src_compile() {
@@ -168,24 +164,39 @@ src_compile() {
# readline pair reads backwards on purpose, DONT change it around, Ok?
# this is because it refers to the building of a bundled readline
# versus the system copy
- use readline && myconf="${myconf} --without-readline"
- use readline || myconf="${myconf} --with-readline"
+ useq readline && myconf="${myconf} --without-readline"
+ useq readline || myconf="${myconf} --with-readline"
- use static \
- && myconf="${myconf} --with-mysqld-ldflags=-all-static --disable-shared" \
- || myconf="${myconf} --enable-shared --enable-static"
+ if useq static ; then
+ myconf="${myconf} --with-mysqld-ldflags=-all-static"
+ myconf="${myconf} --with-client-ldflags=-all-static"
+ myconf="${myconf} --disable-shared"
+ else
+ myconf="${myconf} --enable-shared --enable-static"
+ fi
myconf="${myconf} `use_with tcpd libwrap`"
- use ssl \
- && myconf="${myconf} --with-vio --with-openssl" \
- || myconf="${myconf} --without-openssl"
+ if useq ssl ; then
+ # --with-vio is not needed anymore, it's on by default and
+ # has been removed from configure
+ version_is_at_least "5.0.4_beta" || myconf="${myconf} --with-vio"
+ if version_is_at_least "5.0.6_beta" ; then
+ # yassl-0.96 is young break with gcc-4.0 || amd64
+ #myconf="${myconf} --with-yassl"
+ myconf="${myconf} --with-openssl"
+ else
+ myconf="${myconf} --with-openssl"
+ fi
+ else
+ myconf="${myconf} --without-openssl"
+ fi
- if use debug; then
+ if useq debug; then
myconf="${myconf} --with-debug=full"
else
myconf="${myconf} --without-debug"
- use cluster && myconf="${myconf} --without-ndb-debug"
+ version_is_at_least "4.1.3" && useq cluster && myconf="${myconf} --without-ndb-debug"
fi
# benchmarking stuff needs perl
@@ -205,10 +216,14 @@ src_compile() {
myconf="${myconf} --with-${i}"
done
- if useq utf8; then
- myconf="${myconf} --with-charset=utf8 --with-collation=utf8_general_ci"
- else
- myconf="${myconf} --with-charset=latin1 --with-collation=latin1_swedish_ci"
+ if ! version_is_at_least "5.0_alpha" ; then
+ if version_is_at_least "4.1_alpha" && useq utf8; then
+ myconf="${myconf} --with-charset=utf8"
+ myconf="${myconf} --with-collation=utf8_general_ci"
+ else
+ myconf="${myconf} --with-charset=latin1"
+ myconf="${myconf} --with-collation=latin1_swedish_ci"
+ fi
fi
# lots of chars
@@ -221,12 +236,17 @@ src_compile() {
then
myconf="${myconf} --without-berkeley-db"
else
- use berkdb \
+ useq berkdb \
&& myconf="${myconf} --with-berkeley-db=./bdb" \
|| myconf="${myconf} --without-berkeley-db"
fi
- myconf="${myconf} $(use_with geometry) $(use_with cluster ndbcluster)"
- myconf="${myconf} $(use_with big-tables)"
+
+ if version_is_at_least "4.1.3" ; then
+ myconf="${myconf} $(use_with geometry)"
+ myconf="${myconf} $(use_with cluster ndbcluster)"
+ fi
+
+ version_is_at_least "4.1.11_alpha20050403" && myconf="${myconf} --with-big-tables"
else
for i in ${minimal_exclude_list}; do
myconf="${myconf} --without-${i}"
@@ -238,27 +258,33 @@ src_compile() {
# documentation
myconf="${myconf} `use_with doc docs`"
- if useq extraengine; then
+ if version_is_at_least "4.1.3" && useq extraengine; then
# http://dev.mysql.com/doc/mysql/en/archive-storage-engine.html
myconf="${myconf} --with-archive-storage-engine"
# http://dev.mysql.com/doc/mysql/en/csv-storage-engine.html
- myconf="${myconf} --with-csv-storage-engine"
+ version_is_at_least "4.1.4" \
+ && myconf="${myconf} --with-csv-storage-engine"
# http://dev.mysql.com/doc/mysql/en/federated-description.html
# http://dev.mysql.com/doc/mysql/en/federated-limitations.html
- #if version_is_at_least "5.1.3" ; then
- # einfo "before to use federated engine be sure to read"
- # einfo "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
- # myconf="${myconf} --with-federated-storage-engine"
- #fi
- myconf="${myconf} --with-blackhole-storage-engine"
+ if version_is_at_least "5.0.3" ; then
+ einfo "before to use federated engine be sure to read"
+ einfo "http://dev.mysql.com/doc/mysql/en/federated-limitations.html"
+ myconf="${myconf} --with-federated-storage-engine"
+ fi
+ version_is_at_least "4.1.11_alpha20050403" \
+ && myconf="${myconf} --with-blackhole-storage-engine"
fi
+ myconf="${myconf} `use_with big-tables`"
+
#glibc-2.3.2_pre fix; bug #16496
append-flags "-DHAVE_ERRNO_AS_DEFINE=1"
#the compiler flags are as per their "official" spec ;)
#CFLAGS="${CFLAGS/-O?/} -O3" \
export CXXFLAGS="${CXXFLAGS} -felide-constructors -fno-exceptions -fno-rtti"
+ version_is_at_least "5.0_alpha" \
+ && export CXXFLAGS="${CXXFLAGS} -fno-implicit-templates"
econf \
--libexecdir=/usr/sbin \
@@ -279,29 +305,32 @@ src_compile() {
emake || die "compile problem"
}
-src_install() {
- make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
+src_test() {
+ cd ${S}
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq minimal; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
- enewgroup mysql 60 || die "problem adding group mysql"
- enewuser mysql 60 -1 /dev/null mysql \
- || die "problem adding user mysql"
+ version_is_at_least "5.0.6_beta" \
+ && make test-force \
+ || make test
+ retstatus=$?
- diropts "-m0750"
- if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
- dodir "${DATADIR}"
- keepdir "${DATADIR}"
- chown -R mysql:mysql "${D}/${DATADIR}"
+ # to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
fi
+}
- dodir /var/log/mysql
-
- diropts "-m0755"
- dodir /var/run/mysqld
-
- keepdir /var/run/mysqld /var/log/mysql
- chown -R mysql:mysql \
- ${D}/var/run/mysqld \
- ${D}/var/log/mysql
+src_install() {
+ mysql_get_datadir
+ make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
# move client libs, install a couple of missing headers
local lib=$(get_libdir)
@@ -328,7 +357,7 @@ src_install() {
rm -f ${D}/usr/share/mysql/my-*.cnf # Put them elsewhere
# All of these (ab)use Perl.
- if ! use perl; then
+ if ! useq perl; then
rm -f ${D}/usr/bin/{mysqlhotcopy,mysql_find_rows,mysql_convert_table_format,mysqld_multi,mysqlaccess,mysql_fix_extensions,mysqldumpslow,mysql_zap,mysql_explain_log,mysql_tableinfo,mysql_setpermission}
rm -f ${D}/usr/bin/mysqlhotcopy
rm -rf ${D}/usr/share/mysql/sql-bench
@@ -349,8 +378,9 @@ src_install() {
newins "${FILESDIR}/my.cnf-4.1" my.cnf
- if ! use utf8; then
- sed -i -e "s/utf8/latin1/" ${D}/etc/mysql/my.cnf
+ if version_is_at_least "4.1.3" && ! useq utf8; then
+ sed --in-place -e "s/utf8/latin1/" \
+ ${D}/etc/mysql/my.cnf
fi
# minimal builds don't have the server
@@ -359,6 +389,26 @@ src_install() {
newexe "${FILESDIR}/mysql-4.0.24-r2.rc6" mysql
insinto /etc/logrotate.d
newins "${FILESDIR}/logrotate.mysql" mysql
+
+ #empty dirs...
+ diropts "-m0750"
+ if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
+ dodir "${DATADIR}"
+ keepdir "${DATADIR}"
+ chown -R mysql:mysql "${D}/${DATADIR}"
+ fi
+
+ dodir "/var/log/mysql"
+ touch ${D}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${D}/var/log/mysql/mysql.{log,err}
+
+ diropts "-m0755"
+ dodir "/var/run/mysqld"
+
+ keepdir "/var/run/mysqld" "${D}/var/log/mysql"
+ chown -R mysql:mysql \
+ "${D}/var/run/mysqld" \
+ "${D}/var/log/mysql"
fi
# docs
@@ -372,26 +422,30 @@ src_install() {
fi
}
-src_test() {
- cd ${S}
- einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
- make check || die "make check failed"
- if ! useq minimal; then
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- local retstatus
- addpredict /this-dir-does-not-exist/t9.MYI
- make test
- retstatus=$?
+pkg_preinst() {
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+}
- # to be sure ;)
- pkill -9 -f ${S}/ndb/src/kernel/ndbd 2>/dev/null
- pkill -9 -f ${S}/ndb/src/mgmsrv/ndb_mgmd 2>/dev/null
- pkill -9 -f ${S}/ndb/src/mgmclient/ndb_mgm 2>/dev/null
- pkill -9 -f ${S}/sql/mysqld 2>/dev/null
- [[ $retstatus == 0 ]] || die "make test failed"
- else
- einfo "Skipping server tests due to minimal build."
+pkg_postinst() {
+ mysql_get_datadir
+
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+ if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
+ ewarn "Previous datadir found, it's YOUR job to change"
+ ewarn "ownership and have care of it"
+ fi
fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
}
pkg_config() {
@@ -435,24 +489,31 @@ pkg_config() {
chown -R mysql:mysql ${DATADIR}
chmod 0750 ${ROOT}/${DATADIR}
+ local options=""
local sqltmp="$(emktemp)"
local help_tables="${ROOT}/usr/share/mysql/fill_help_tables.sql"
- # Filling timezones, see
- # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
- ${ROOT}/usr/bin/mysql_tzinfo_to_sql ${ROOT}/usr/share/zoneinfo > "${sqltmp}"
- if [[ -r "${help_tables}" ]] ; then
- cat "${help_tables}" >> "${sqltmp}"
+ if version_is_at_least "4.1.3" ; then
+ options="--skip-ndbcluster"
+
+ # Filling timezones, see
+ # http://dev.mysql.com/doc/mysql/en/time-zone-support.html
+ ${ROOT}/usr/bin/mysql_tzinfo_to_sql ${ROOT}/usr/share/zoneinfo \
+ > "${sqltmp}"
+
+ if [[ -r "${help_tables}" ]] ; then
+ cat "${help_tables}" >> "${sqltmp}"
+ fi
fi
local socket=${ROOT}/var/run/mysqld/mysqld.sock
local mysqld="${ROOT}/usr/sbin/mysqld \
+ ${options} \
--skip-grant-tables \
--basedir=${ROOT}/usr \
--datadir=${ROOT}/var/lib/mysql \
--skip-innodb \
--skip-bdb \
- --skip-ndbcluster \
--max_allowed_packet=8M \
--net_buffer_length=16K \
--socket=${socket} \
@@ -486,36 +547,3 @@ pkg_config() {
rm "${sqltmp}"
einfo "done"
}
-
-pkg_postinst() {
- mysql_get_datadir
-
- if ! useq minimal; then
- #empty dirs...
- [[ "${PREVIOUS_DATADIR}" != "yes" ]] \
- && [ -d "${ROOT}/${DATADIR}" ] || install -d -m0750 -o mysql -g mysql ${ROOT}/var/lib/mysql
- [ -d "${ROOT}/var/run/mysqld" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
- [ -d "${ROOT}/var/log/mysql" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- # secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql ${ROOT}/${DATADIR}
-
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
- einfo "if this is a new install."
- einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}
diff --git a/dev-db/mysql/mysql-5.0.12_beta.ebuild b/dev-db/mysql/mysql-5.0.12_beta.ebuild
index 9ecc8332708b..a44ad7477c16 100644
--- a/dev-db/mysql/mysql-5.0.12_beta.ebuild
+++ b/dev-db/mysql/mysql-5.0.12_beta.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.2 2005/09/08 14:57:22 vivo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql/mysql-5.0.12_beta.ebuild,v 1.3 2005/09/09 11:42:28 vivo Exp $
inherit eutils flag-o-matic versionator
@@ -40,10 +40,6 @@ if version_is_at_least "4.1.3" ; then
IUSE="${IUSE} cluster utf8 geometry extraengine"
fi
-shopt -s extglob
-export LC_ALL="C"
-unset LC_COLLATE
-
mysql_upgrade_error() {
mysql_get_datadir
ewarn "Sorry plain upgrade from version of MySQL before 4.1.4 is NOT supported."
@@ -109,7 +105,13 @@ pkg_setup() {
die
fi
fi
+
mysql_upgrade_warning
+
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+
}
src_unpack() {
@@ -148,11 +150,15 @@ src_unpack() {
|| die "failed reconfigure step 02"
automake --force --add-missing && autoconf \
|| die "failed reconfigure step 03"
- if ! version_is_at_least "5.1_alpha" ; then
- pushd innobase && aclocal && autoheader && autoconf && automake \
- || die "failed innobase reconfigure"
- popd
+
+ if version_is_at_least "5.1_alpha" ; then
+ pushd storage/innobase || die "failed chdir"
+ else
+ pushd innobase || die "failed chroot"
fi
+ aclocal && autoheader && autoconf && automake
+ popd
+
pushd bdb/dist && sh s_all \
|| die "failed bdb reconfigure"
popd
@@ -306,30 +312,32 @@ src_compile() {
emake || die "compile problem"
}
-src_install() {
-
- make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
+src_test() {
+ cd ${S}
+ einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
+ make check || die "make check failed"
+ if ! useq minimal; then
+ einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
+ local retstatus
+ addpredict /this-dir-does-not-exist/t9.MYI
- enewgroup mysql 60 || die "problem adding group mysql"
- enewuser mysql 60 -1 /dev/null mysql \
- || die "problem adding user mysql"
+ version_is_at_least "5.0.6_beta" \
+ && make test-force \
+ || make test
+ retstatus=$?
- diropts "-m0750"
- if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
- dodir "${DATADIR}"
- keepdir "${DATADIR}"
- chown -R mysql:mysql "${D}/${DATADIR}"
+ # to be sure ;)
+ pkill -9 -f "${S}/ndb" 2>/dev/null
+ pkill -9 -f "${S}/sql" 2>/dev/null
+ [[ $retstatus -eq 0 ]] || die "make test failed"
+ else
+ einfo "Skipping server tests due to minimal build."
fi
+}
- dodir /var/log/mysql
-
- diropts "-m0755"
- dodir /var/run/mysqld
-
- keepdir /var/run/mysqld /var/log/mysql
- chown -R mysql:mysql \
- ${D}/var/run/mysqld \
- ${D}/var/log/mysql
+src_install() {
+ mysql_get_datadir
+ make install DESTDIR="${D}" benchdir_root="/usr/share/mysql" || die
# move client libs, install a couple of missing headers
local lib=$(get_libdir)
@@ -388,6 +396,26 @@ src_install() {
newexe "${FILESDIR}/mysql-4.0.24-r2.rc6" mysql
insinto /etc/logrotate.d
newins "${FILESDIR}/logrotate.mysql" mysql
+
+ #empty dirs...
+ diropts "-m0750"
+ if [[ "${PREVIOUS_DATADIR}" != "yes" ]] ; then
+ dodir "${DATADIR}"
+ keepdir "${DATADIR}"
+ chown -R mysql:mysql "${D}/${DATADIR}"
+ fi
+
+ dodir "/var/log/mysql"
+ touch ${D}/var/log/mysql/mysql.{log,err}
+ chmod 0660 ${D}/var/log/mysql/mysql.{log,err}
+
+ diropts "-m0755"
+ dodir "/var/run/mysqld"
+
+ keepdir "/var/run/mysqld" "${D}/var/log/mysql"
+ chown -R mysql:mysql \
+ "${D}/var/run/mysqld" \
+ "${D}/var/log/mysql"
fi
# docs
@@ -401,27 +429,30 @@ src_install() {
fi
}
-src_test() {
- cd ${S}
- einfo ">>> Test phase [check]: ${CATEGORY}/${PF}"
- make check || die "make check failed"
- if ! useq minimal; then
- einfo ">>> Test phase [test]: ${CATEGORY}/${PF}"
- local retstatus
- addpredict /this-dir-does-not-exist/t9.MYI
+pkg_preinst() {
+ enewgroup mysql 60 || die "problem adding group mysql"
+ enewuser mysql 60 -1 /dev/null mysql \
+ || die "problem adding user mysql"
+}
- version_is_at_least "5.0.6_beta" \
- && make test-force \
- || make test
- retstatus=$?
+pkg_postinst() {
+ mysql_get_datadir
- # to be sure ;)
- pkill -9 -f "${S}/ndb" 2>/dev/null
- pkill -9 -f "${S}/sql" 2>/dev/null
- [[ $retstatus -eq 0 ]] || die "make test failed"
- else
- einfo "Skipping server tests due to minimal build."
+ if ! useq minimal; then
+ # your friendly public service announcement...
+ einfo
+ einfo "You might want to run:"
+ einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
+ einfo "if this is a new install."
+ einfo
+ if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
+ ewarn "Previous datadir found, it's YOUR job to change"
+ ewarn "ownership and have care of it"
+ fi
fi
+
+ mysql_upgrade_warning
+ einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
}
pkg_config() {
@@ -523,36 +554,3 @@ pkg_config() {
rm "${sqltmp}"
einfo "done"
}
-
-pkg_postinst() {
- mysql_get_datadir
-
- if ! useq minimal; then
- #empty dirs...
- [[ "${PREVIOUS_DATADIR}" != "yes" ]] \
- && [ -d "${ROOT}/${DATADIR}" ] || install -d -m0750 -o mysql -g mysql ${ROOT}/var/lib/mysql
- [ -d "${ROOT}/var/run/mysqld" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/run/mysqld
- [ -d "${ROOT}/var/log/mysql" ] || install -d -m0755 -o mysql -g mysql ${ROOT}/var/log/mysql
-
- # secure the logfiles... does this bother anybody?
- touch ${ROOT}/var/log/mysql/mysql.{log,err}
- chown mysql:mysql ${ROOT}/var/log/mysql/mysql*
- chmod 0660 ${ROOT}/var/log/mysql/mysql*
- # secure some directories
- chmod 0750 ${ROOT}/var/log/mysql ${ROOT}/${DATADIR}
-
- # your friendly public service announcement...
- einfo
- einfo "You might want to run:"
- einfo "\"ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config\""
- einfo "if this is a new install."
- einfo
- if [[ "${PREVIOUS_DATADIR}" == "yes" ]] ; then
- ewarn "Previous datadir found, it's YOUR job to change"
- ewarn "ownership and have care of it"
- fi
- fi
-
- mysql_upgrade_warning
- einfo "InnoDB is not optional as of MySQL-4.0.24, at the request of upstream."
-}