summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild')
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild20
1 files changed, 14 insertions, 6 deletions
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
index ec7bab4d289d..9f6ade36c463 100644
--- a/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild
@@ -1,20 +1,29 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild,v 1.1 2004/02/24 04:04:37 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.2.ebuild,v 1.1.1.1 2005/11/30 10:11:49 chriswhite Exp $
+
+inherit eutils
MY_PN="super-smack"
MY_P="${MY_PN}-${PV}"
DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL"
HOMEPAGE="http://jeremy.zawodny.com/mysql/${MY_PN}/"
-SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+SRC_URI="http://jeremy.zawodny.com/mysql/${MY_PN}/${MY_P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE="mysql postgres"
+
DEPEND="mysql? ( dev-db/mysql )
- postgres? ( dev-db/postgresql )"
+ postgres? ( dev-db/postgresql )"
+
S=${WORKDIR}/${MY_P}
+pkg_setup() {
+ use !mysql && use !postgres && die "You need to use at least one of USE=mysql or USE=postgres for benchmarking!"
+}
+
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${P}.destdir.patch
@@ -28,7 +37,6 @@ src_compile() {
use postgres && myconf="${myconf} --with-pgsql"
myconf="${myconf} --with-datadir=/var/tmp/${MY_PN}"
myconf="${myconf} --with-smacks-dir=/usr/share/${MY_PN}"
- echo $myconf
econf ${myconf} || die
emake || die
}