summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/asio/ChangeLog13
-rw-r--r--dev-cpp/asio/asio-1.4.1.ebuild48
2 files changed, 57 insertions, 4 deletions
diff --git a/dev-cpp/asio/ChangeLog b/dev-cpp/asio/ChangeLog
index 3b7e074a996c..029df4073b3e 100644
--- a/dev-cpp/asio/ChangeLog
+++ b/dev-cpp/asio/ChangeLog
@@ -1,10 +1,15 @@
# ChangeLog for dev-cpp/asio
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.15 2008/06/11 16:21:56 drac Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/ChangeLog,v 1.16 2009/05/12 08:34:26 ssuominen Exp $
+
+*asio-1.4.1 (12 May 2009)
+
+ 12 May 2009; Samuli Suominen <ssuominen@gentoo.org> +asio-1.4.1.ebuild:
+ Version bump.
*asio-1.1.0 (11 Jun 2008)
- 11 Jun 2008; Samuli Suominen <drac@gentoo.org> +asio-1.1.0.ebuild:
+ 11 Jun 2008; Samuli Suominen <ssuominen@gentoo.org> +asio-1.1.0.ebuild:
Version bump.
05 Feb 2008; Tiziano Müller <dev-zero@gentoo.org>
@@ -14,7 +19,7 @@
05 Feb 2008; Christian Faulhammer <opfer@gentoo.org> asio-0.3.9.ebuild:
stable x86, bug 209002
- 05 Feb 2008; Samuli Suominen <drac@gentoo.org> asio-0.3.9.ebuild:
+ 05 Feb 2008; Samuli Suominen <ssuominen@gentoo.org> asio-0.3.9.ebuild:
amd64 stable wrt #209002
*asio-0.3.9 (24 Dec 2007)
diff --git a/dev-cpp/asio/asio-1.4.1.ebuild b/dev-cpp/asio/asio-1.4.1.ebuild
new file mode 100644
index 000000000000..004b3d1712e7
--- /dev/null
+++ b/dev-cpp/asio/asio-1.4.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/asio/asio-1.4.1.ebuild,v 1.1 2009/05/12 08:34:26 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Asynchronous Network Library"
+HOMEPAGE="http://asio.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples ssl test"
+
+RDEPEND="ssl? ( dev-libs/openssl )
+ >=dev-libs/boost-1.34.1"
+DEPEND="${DEPEND}"
+
+src_prepare() {
+ if ! use test; then
+ # Don't build nor install any examples or unittests
+ # since we don't have a script to run them
+ cat > src/Makefile.in <<-EOF
+all:
+
+install:
+ EOF
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+
+ if use doc ; then
+ dohtml -r doc/*
+ fi
+
+ if use examples; then
+ if use test; then
+ # Get rid of the object files
+ emake clean || die "emake clean failed"
+ fi
+ insinto /usr/share/doc/${PF}
+ doins -r src/examples
+ fi
+}