summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tbb/tbb-3.0.018.ebuild')
-rw-r--r--dev-cpp/tbb/tbb-3.0.018.ebuild80
1 files changed, 80 insertions, 0 deletions
diff --git a/dev-cpp/tbb/tbb-3.0.018.ebuild b/dev-cpp/tbb/tbb-3.0.018.ebuild
new file mode 100644
index 000000000000..2aa1917a6517
--- /dev/null
+++ b/dev-cpp/tbb/tbb-3.0.018.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/tbb/tbb-3.0.018.ebuild,v 1.1 2010/05/05 01:42:59 bicatali Exp $
+
+EAPI=2
+inherit eutils versionator toolchain-funcs alternatives
+# url number
+MYU="78/154"
+# release update
+MYR=""
+
+PV1="$(get_version_component_range 1)"
+PV2="$(get_version_component_range 2)"
+PV3="$(get_version_component_range 3)"
+MYP="${PN}${PV1}${PV2}_${PV3}oss"
+
+DESCRIPTION="High level abstract threading library"
+HOMEPAGE="http://www.threadingbuildingblocks.org/"
+SRC_URI="http://www.threadingbuildingblocks.org/uploads/${MYU}/${PV1}.${PV2}/${MYP}_src.tgz"
+LICENSE="GPL-2-with-exceptions"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc examples"
+
+DEPEND="!<=dev-cpp/tbb-2.1.016"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MYP}"
+
+src_prepare() {
+ sed -i \
+ -e "s/-O2/${CXXFLAGS}/g" \
+ build/*.inc \
+ || die
+}
+
+src_compile() {
+ if [[ $(tc-getCXX) == *g++ ]]; then
+ myconf="compiler=gcc"
+ elif [[ $(tc-getCXX) == *ic*c ]]; then
+ myconf="compiler=icc"
+ fi
+ # from the Makefile, split debug
+ cd src
+ emake ${myconf} tbb_release tbbmalloc_release || die "emake failed"
+ if use debug || use examples; then
+ emake ${myconf} tbb_debug tbbmalloc_debug || die "emake debug failed"
+ fi
+}
+
+src_test() {
+ cd src
+ emake -j1 ${myconf} test_release || die "emake test failed"
+ if use debug || use examples; then
+ emake ${myconf} test_debug tbbmalloc_test_debug || die "emake test debug failed"
+ fi
+
+}
+
+src_install(){
+ for l in $(find build -name lib\*.so.\*); do
+ dolib.so ${l} || die
+ local bl=$(basename ${l})
+ dosym ${bl} /usr/$(get_libdir)/${bl%.*}
+ done
+ insinto /usr
+ doins -r include || die
+
+ dodoc README CHANGES doc/Release_Notes.txt
+ if use doc ; then
+ insinto /usr/share/doc/${PF}
+ doins -r doc/html || die
+ fi
+ if use examples ; then
+ insinto /usr/share/doc/${PF}/examples/build
+ doins build/*.inc || die
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples || die
+ fi
+}