summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gconfmm/gconfmm-2.28.2.ebuild')
-rw-r--r--dev-cpp/gconfmm/gconfmm-2.28.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild b/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild
new file mode 100644
index 000000000000..71ce83938543
--- /dev/null
+++ b/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gconfmm/gconfmm-2.28.2.ebuild,v 1.1 2010/06/17 16:01:33 pacho Exp $
+
+inherit gnome2 eutils
+
+DESCRIPTION="C++ bindings for GConf"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=gnome-base/gconf-2.4
+ >=dev-cpp/glibmm-2.12
+ >=dev-cpp/gtkmm-2.4"
+
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+DOCS="AUTHORS COPYING* ChangeLog NEWS README INSTALL"
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if ! use examples; then
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
+ die "sed Makefile.in failed"
+ fi
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ cd "${S}/docs/reference"
+ make all
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/* docs/images/*
+ fi
+
+ if use examples; then
+ find examples -type d -name '.deps' -exec rm -fr {} \; 2>/dev/null
+ cp -R examples "${D}/usr/share/doc/${PF}"
+ fi
+}