summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/gentoo-syntax/ChangeLog8
-rw-r--r--app-vim/gentoo-syntax/gentoo-syntax-20090220.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/app-vim/gentoo-syntax/ChangeLog b/app-vim/gentoo-syntax/ChangeLog
index a95f6092b96f..abff1b729aa8 100644
--- a/app-vim/gentoo-syntax/ChangeLog
+++ b/app-vim/gentoo-syntax/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-vim/gentoo-syntax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.91 2009/02/20 00:32:19 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/ChangeLog,v 1.92 2009/02/20 16:03:01 darkside Exp $
+
+*gentoo-syntax-20090220 (20 Feb 2009)
+
+ 20 Feb 2009; Jeremy Olexa <darkside@gentoo.org>
+ +gentoo-syntax-20090220.ebuild:
+ New version bump, fixes bugs 253401 & 254208
20 Feb 2009; Tiago Cunha <tcunha@gentoo.org>
gentoo-syntax-20081006.ebuild:
diff --git a/app-vim/gentoo-syntax/gentoo-syntax-20090220.ebuild b/app-vim/gentoo-syntax/gentoo-syntax-20090220.ebuild
new file mode 100644
index 000000000000..2e2166024c48
--- /dev/null
+++ b/app-vim/gentoo-syntax/gentoo-syntax-20090220.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/gentoo-syntax/gentoo-syntax-20090220.ebuild,v 1.1 2009/02/20 16:03:01 darkside Exp $
+
+inherit eutils vim-plugin
+
+DESCRIPTION="vim plugin: Gentoo Ebuild, Eclass, GLEP, ChangeLog and Portage Files syntax highlighting, filetype and indent settings"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="ignore-glep31"
+
+VIM_PLUGIN_HELPFILES="gentoo-syntax"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ if use ignore-glep31 ; then
+ for f in ftplugin/*.vim ; do
+ ebegin "Removing UTF-8 rules from ${f} ..."
+ sed -i -e 's~\(setlocal fileencoding=utf-8\)~" \1~' ${f} \
+ || die "waah! bad sed voodoo. need more goats."
+ eend $?
+ done
+ fi
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ if use ignore-glep31 1>/dev/null ; then
+ ewarn "You have chosen to disable the rules which ensure GLEP 31"
+ ewarn "compliance. When editing ebuilds, please make sure you get"
+ ewarn "the character set correct."
+ else
+ elog "Note for developers and anyone else who edits ebuilds:"
+ elog " This release of gentoo-syntax now contains filetype rules to set"
+ elog " fileencoding for ebuilds and ChangeLogs to utf-8 as per GLEP 31."
+ elog " If you find this feature breaks things, please submit a bug and"
+ elog " assign it to vim@gentoo.org. You can use the 'ignore-glep31' USE"
+ elog " flag to remove these rules."
+ fi
+ echo
+ epause 5
+}