summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/slimv/slimv-0.8.4.ebuild')
-rw-r--r--app-vim/slimv/slimv-0.8.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/slimv/slimv-0.8.4.ebuild b/app-vim/slimv/slimv-0.8.4.ebuild
new file mode 100644
index 000000000000..0bff18cf551e
--- /dev/null
+++ b/app-vim/slimv/slimv-0.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/slimv/slimv-0.8.4.ebuild,v 1.1 2011/06/25 09:25:37 radhermit Exp $
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+VIM_PLUGIN_HELPFILES="slimv.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}.vim-* "${S}"
+}
+
+src_prepare() {
+ # Remove emacs related files
+ rm -rf slime swank-clojure
+
+ rm README
+}