summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xpdf/xpdf-2.02.1.ebuild')
-rw-r--r--app-text/xpdf/xpdf-2.02.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-text/xpdf/xpdf-2.02.1.ebuild b/app-text/xpdf/xpdf-2.02.1.ebuild
new file mode 100644
index 000000000000..9aaaa08e3858
--- /dev/null
+++ b/app-text/xpdf/xpdf-2.02.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-2.02.1.ebuild,v 1.1 2003/06/19 09:36:06 aliz Exp $
+
+IUSE="motif"
+
+MY_PV=${PV/.1/pl1}
+
+S=${WORKDIR}/${PN}-${MY_PV}
+DESCRIPTION="An X Viewer for PDF Files"
+HOMEPAGE="http://www.foolabs.com/xpdf/xpdf.html"
+SRC_URI="ftp://ftp.foolabs.com/pub/xpdf/${PN}-${MY_PV}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
+
+DEPEND="motif? ( virtual/x11
+ virtual/motif )
+ >=media-libs/freetype-2.0.5
+ >=media-libs/t1lib-1.3
+ app-text/ghostscript"
+
+src_compile() {
+ econf \
+ --enable-freetype2 \
+ --with-freetype2-includes=/usr/include/freetype2 \
+ --with-gzip || die
+
+ make ${MAKEOPTS} || die
+}
+
+
+src_install() {
+ make DESTDIR=${D} install || die
+ prepallman
+ dodoc README ANNOUNCE CHANGES
+ insinto /etc
+ doins ${FILESDIR}/xpdfrc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "HINT: To have even nicer results add these lines to your ~/.xpdfrc"
+ einfo
+ einfo " include /etc/xpdfrc"
+ einfo " t1libControl high"
+ einfo " freetypeControl high"
+ einfo
+}