summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/texi2html/texi2html-1.78.ebuild')
-rw-r--r--app-text/texi2html/texi2html-1.78.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/texi2html/texi2html-1.78.ebuild b/app-text/texi2html/texi2html-1.78.ebuild
new file mode 100644
index 000000000000..d46d5c1bf2eb
--- /dev/null
+++ b/app-text/texi2html/texi2html-1.78.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/texi2html/texi2html-1.78.ebuild,v 1.1 2007/11/23 18:21:44 aballier Exp $
+
+DESCRIPTION="Perl script that converts Texinfo to HTML"
+HOMEPAGE="http://www.nongnu.org/texi2html/"
+SRC_URI="http://download.savannah.gnu.org/releases/texi2html/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-lang/perl-5.6.1"
+
+src_install() {
+ #yes, htmldir line is correct, no ${D}
+ emake DESTDIR="${D}" \
+ htmldir=/usr/share/doc/${PF}/html \
+ install || die "Installation Failed"
+
+ dodoc AUTHORS ChangeLog INTRODUCTION NEWS README TODO
+}
+
+pkg_preinst() {
+ rm -f "${ROOT}"/usr/bin/texi2html
+}