summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/enchant/enchant-1.2.2.ebuild')
-rw-r--r--app-text/enchant/enchant-1.2.2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-text/enchant/enchant-1.2.2.ebuild b/app-text/enchant/enchant-1.2.2.ebuild
new file mode 100644
index 000000000000..c31164394d40
--- /dev/null
+++ b/app-text/enchant/enchant-1.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enchant/enchant-1.2.2.ebuild,v 1.1 2006/02/26 16:25:18 foser Exp $
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="http://www.abisource.com/enchant/"
+SRC_URI="http://www.abisource.com/downloads/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+# FIXME : some sort of proper spellchecker selection needed
+
+# The || is meant to make sure there is a a default spell lib to work with
+# 25 Aug 2003; foser <foser@gentoo.org>
+
+RDEPEND=">=dev-libs/glib-2
+ || ( virtual/aspell-dict app-text/ispell app-text/hspell app-text/hunspell )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+
+ econf || die
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc AUTHORS BUGS ChangeLog HACKING MAINTAINERS NEWS README TODO
+
+}