summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/csvfix/csvfix-1.3.ebuild')
-rw-r--r--app-text/csvfix/csvfix-1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-text/csvfix/csvfix-1.3.ebuild b/app-text/csvfix/csvfix-1.3.ebuild
new file mode 100644
index 000000000000..49c46e49afc5
--- /dev/null
+++ b/app-text/csvfix/csvfix-1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/csvfix/csvfix-1.3.ebuild,v 1.1 2012/05/31 18:25:41 radhermit Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs versionator
+
+MY_PV="$(delete_all_version_separators)"
+DESCRIPTION="A stream editor for manipulating CSV files"
+HOMEPAGE="http://code.google.com/p/csvfix/"
+SRC_URI="http://dev.gentoo.org/~radhermit/dist/${P}.tar.bz2
+ doc? ( http://csvfix.googlecode.com/files/CSVfix_man_html_${MY_PV}0.zip )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-libs/expat"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${PN}-1.10a-tests.patch
+
+ edos2unix $(find csvfix/tests -type f)
+}
+
+src_compile() {
+ emake CC="$(tc-getCXX)" AR="$(tc-getAR)" lin
+}
+
+src_test() {
+ cd ${PN}/tests
+ chmod +x run1 runtests
+ ./runtests || die "tests failed"
+}
+
+src_install() {
+ dobin csvfix/bin/csvfix
+ use doc && dohtml -r "${WORKDIR}"/${PN}${MY_PV}/*
+}