summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aspell/aspell-0.60.5.ebuild')
-rw-r--r--app-text/aspell/aspell-0.60.5.ebuild107
1 files changed, 0 insertions, 107 deletions
diff --git a/app-text/aspell/aspell-0.60.5.ebuild b/app-text/aspell/aspell-0.60.5.ebuild
deleted file mode 100644
index f793b5333b18..000000000000
--- a/app-text/aspell/aspell-0.60.5.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.5.ebuild,v 1.20 2011/02/06 05:34:40 leio Exp $
-
-# N.B. This is before inherit of autotools, as autotools.eclass adds the
-# relevant dependencies to DEPEND.
-WANT_AUTOMAKE="1.10"
-
-inherit libtool eutils flag-o-matic autotools
-
-DESCRIPTION="A spell checker replacement for ispell"
-HOMEPAGE="http://aspell.net/"
-SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="gpm nls examples"
-# Note; app-text/aspell-0.6 and app-dicts/aspell-en-0.6 must go stable together
-
-# Build PDEPEND from list of language codes provided in the tree.
-# The PDEPEND string is static - this code just makes it easier to maintain.
-def="app-dicts/aspell-en"
-for l in \
- "af" "be" "bg" "br" "ca" "cs" "cy" "da" "de" "el" \
- "en" "eo" "es" "et" "fi" "fo" "fr" "ga" "gl" "he" \
- "hr" "is" "it" "nl" "no" "pl" "pt" "ro" "ru" "sk" \
- "sl" "sr" "sv" "uk" "vi"; do
- dep="linguas_${l}? ( app-dicts/aspell-${l} )"
- [[ -z ${PDEPEND} ]] &&
- PDEPEND="${dep}" ||
- PDEPEND="${PDEPEND}
-${dep}"
- def="!linguas_${l}? ( ${def} )"
- IUSE="${IUSE} linguas_${l}"
-done
-PDEPEND="${PDEPEND}
-${def}"
-
-RDEPEND=">=sys-libs/ncurses-5.2
- gpm? ( sys-libs/gpm )
- nls? ( virtual/libintl )
- !=app-dicts/aspell-en-0.5*"
-# English dictionary 0.5 is incompatible with aspell-0.6
-
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/aspell-0.60.3-templateinstantiations.patch
- epatch "${FILESDIR}/${P}-nls.patch"
- epatch "${FILESDIR}/${P}-gcc-4.3.patch"
-
- eautomake
- elibtoolize --reverse-deps
-}
-
-src_compile() {
- use gpm && append-ldflags -lgpm
- filter-flags -fno-rtti
- filter-flags -fvisibility=hidden #77109
- filter-flags -maltivec -mabi=altivec
- use ppc && append-flags -mno-altivec
-
- econf \
- $(use_enable nls) \
- --disable-static \
- --sysconfdir=/etc/aspell \
- --enable-docdir=/usr/share/doc/${PF} || die
-
- emake || die
-}
-
-src_install() {
- dodoc README* TODO
-
- make DESTDIR="${D}" install || die
- mv "${D}"/usr/share/doc/${PF}/man-html "${D}"/usr/share/doc/${PF}/html
- mv "${D}"/usr/share/doc/${PF}/man-text "${D}"/usr/share/doc/${PF}/text
-
- # install ispell/aspell compatibility scripts
- exeinto /usr/bin
- newexe scripts/ispell ispell-aspell
- newexe scripts/spell spell-aspell
-
- if use examples ; then
- cd examples
- make clean || die
- docinto examples
- dodoc "${S}"/examples/*
- fi
-}
-
-pkg_postinst() {
- elog "You will need to install a dictionary now. Please choose an"
- elog "aspell-<LANG> dictionary from the app-dicts category"
- elog "After installing an aspell dictionary for your language(s),"
- elog "You may use the aspell-import utility to import your personal"
- elog "dictionaries from ispell, pspell and the older aspell"
-
- ewarn ""
- ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
- ewarn ""
- ebeep 5
-}