summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/aiksaurus')
-rw-r--r--app-text/aiksaurus/ChangeLog6
-rw-r--r--app-text/aiksaurus/aiksaurus-1.2.1.ebuild19
2 files changed, 19 insertions, 6 deletions
diff --git a/app-text/aiksaurus/ChangeLog b/app-text/aiksaurus/ChangeLog
index bbe1467bc1b5..fdcd9dbf058c 100644
--- a/app-text/aiksaurus/ChangeLog
+++ b/app-text/aiksaurus/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/aiksaurus
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/ChangeLog,v 1.34 2008/03/29 01:45:22 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/ChangeLog,v 1.35 2008/09/24 13:14:18 aballier Exp $
+
+ 24 Sep 2008; Alexis Ballier <aballier@gentoo.org> aiksaurus-1.2.1.ebuild:
+ Keyword x86-fbsd, call libtoolize to have it installable and with a sane
+ .so versionning there, move patching to src_unpack.
29 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
+files/aiksaurus-1.2.1-gcc43.patch, aiksaurus-1.2.1.ebuild:
diff --git a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
index 5a774552ac84..3b92117e994e 100644
--- a/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
+++ b/app-text/aiksaurus/aiksaurus-1.2.1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/aiksaurus-1.2.1.ebuild,v 1.13 2008/03/29 01:45:22 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aiksaurus/aiksaurus-1.2.1.ebuild,v 1.14 2008/09/24 13:14:18 aballier Exp $
-inherit flag-o-matic eutils
+inherit flag-o-matic eutils libtool
IUSE="gtk"
@@ -12,18 +12,27 @@ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
RDEPEND="gtk? ( >=x11-libs/gtk+-2 )"
DEPEND="${RDEPEND}
gtk? ( dev-util/pkgconfig )"
-src_compile() {
- filter-flags -fno-exceptions
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
# Fixes bug 214248.
epatch "${FILESDIR}/${P}-gcc43.patch"
+ # Needed to make relink work on FreeBSD, without it won't install.
+ # Also needed for a sane .so versionning there.
+ elibtoolize
+}
+
+src_compile() {
+ filter-flags -fno-exceptions
+
econf $(use_with gtk) || die "configure failed"
emake || die "emake failed"
}