summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/getdelta/ChangeLog9
-rw-r--r--app-portage/getdelta/getdelta-0.7.9-r2.ebuild43
2 files changed, 50 insertions, 2 deletions
diff --git a/app-portage/getdelta/ChangeLog b/app-portage/getdelta/ChangeLog
index 943067ef2080..d0d97ff8707f 100644
--- a/app-portage/getdelta/ChangeLog
+++ b/app-portage/getdelta/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-portage/getdelta
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/getdelta/ChangeLog,v 1.23 2012/08/20 02:55:43 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/getdelta/ChangeLog,v 1.24 2013/03/17 04:55:34 patrick Exp $
+
+*getdelta-0.7.9-r2 (17 Mar 2013)
+
+ 17 Mar 2013; Patrick Lauer <patrick@gentoo.org> +getdelta-0.7.9-r2.ebuild:
+ Fix make.conf location #461726
*getdelta-0.7.9-r1 (20 Aug 2012)
diff --git a/app-portage/getdelta/getdelta-0.7.9-r2.ebuild b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
new file mode 100644
index 000000000000..f3d107bfa319
--- /dev/null
+++ b/app-portage/getdelta/getdelta-0.7.9-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/getdelta/getdelta-0.7.9-r2.ebuild,v 1.1 2013/03/17 04:55:34 patrick Exp $
+
+inherit eutils
+
+DESCRIPTION="dynamic deltup client"
+HOMEPAGE="http://linux01.gwdg.de/~nlissne/"
+SRC_URI="http://linux01.gwdg.de/~nlissne/${PN}-0.7.8.tar.bz2"
+SLOT="0"
+IUSE=""
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~sparc ~x86"
+
+RDEPEND="app-portage/deltup
+ dev-util/bdelta"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}.patch
+}
+
+src_install () {
+ # portage has moved make.globals, so we just hotfix it
+ sed -i -e "s:/etc/make.globals:/usr/share/portage/config/make.globals:g" "${WORKDIR}"/getdelta.sh || die "Couldn't fix make.globals path"
+
+ # make.conf has now two locations. This should fix it ( #461726 )
+ sed -i -e "s:source /etc/make.conf:source /etc/make.conf || source /etc/portage/make.conf:" "${WORKDIR}"/getdelta.sh || die "Couldn't fix make.conf path"
+
+ sed -i -e "s:/bin/sh:/bin/bash:" "${WORKDIR}"/getdelta.sh || die
+ dobin "${WORKDIR}"/getdelta.sh || die
+}
+
+pkg_postinst() {
+ elog "You need to put"
+ elog "FETCHCOMMAND=\"/usr/bin/getdelta.sh \\\${URI}\""
+ elog "into your /etc/make.conf to make use of getdelta"
+
+ # make sure permissions are ok
+ touch "${ROOT}"/var/log/getdelta.log
+ mkdir -p "${ROOT}"/etc/deltup
+ chown -R portage:portage "${ROOT}"/{var/log/getdelta.log,etc/deltup}
+ chmod -R ug+rwX "${ROOT}"/{var/log/getdelta.log,etc/deltup}
+}