summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild')
-rw-r--r--app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild b/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild
index 862205150937..9e12c0de6873 100644
--- a/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild
+++ b/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild,v 1.7 2013/02/02 22:23:47 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/usbmuxd/usbmuxd-1.0.8-r1.ebuild,v 1.8 2014/05/30 11:52:33 ssuominen Exp $
EAPI=4
inherit cmake-utils user udev
@@ -15,7 +15,8 @@ KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86"
IUSE=""
RDEPEND=">=app-pda/libplist-1.8-r1
- virtual/libusb:1"
+ virtual/libusb:1
+ !app-pda/libusbmuxd"
DEPEND="${RDEPEND}
virtual/os-headers
virtual/pkgconfig"
@@ -26,8 +27,8 @@ pkg_setup() {
}
src_configure() {
- if [[ $(udev_get_udevdir) != "/lib/udev" ]]; then
- sed -i -e "/rules/s:/lib/udev:$(udev_get_udevdir):" udev/CMakeLists.txt || die
+ if [[ $(get_udevdir) != "/lib/udev" ]]; then
+ sed -i -e "/rules/s:/lib/udev:$(get_udevdir):" udev/CMakeLists.txt || die
fi
cmake-utils_src_configure