summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/texmaker')
-rw-r--r--app-office/texmaker/ChangeLog8
-rw-r--r--app-office/texmaker/files/texmaker-3.01-hunspell.patch155
-rw-r--r--app-office/texmaker/metadata.xml4
-rw-r--r--app-office/texmaker/texmaker-3.01.ebuild62
4 files changed, 228 insertions, 1 deletions
diff --git a/app-office/texmaker/ChangeLog b/app-office/texmaker/ChangeLog
index 08c67e1feb0a..264bfa82ac88 100644
--- a/app-office/texmaker/ChangeLog
+++ b/app-office/texmaker/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/texmaker
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.78 2011/04/04 06:56:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/ChangeLog,v 1.79 2011/04/17 16:11:24 jlec Exp $
+
+*texmaker-3.01 (17 Apr 2011)
+
+ 17 Apr 2011; Justin Lecher <jlec@gentoo.org> +texmaker-3.01.ebuild,
+ +files/texmaker-3.01-hunspell.patch, metadata.xml:
+ Version Bump, added myself as maintainer
*texmaker-3.00 (04 Apr 2011)
diff --git a/app-office/texmaker/files/texmaker-3.01-hunspell.patch b/app-office/texmaker/files/texmaker-3.01-hunspell.patch
new file mode 100644
index 000000000000..d8d69d11413a
--- /dev/null
+++ b/app-office/texmaker/files/texmaker-3.01-hunspell.patch
@@ -0,0 +1,155 @@
+ configdialog.cpp | 2 +-
+ latexeditor.h | 2 +-
+ latexeditorview.h | 2 +-
+ latexhighlighter.h | 2 +-
+ spellerdialog.h | 2 +-
+ texmaker.h | 2 +-
+ texmaker.pro | 36 +++---------------------------------
+ 7 files changed, 9 insertions(+), 39 deletions(-)
+
+diff --git a/configdialog.cpp b/configdialog.cpp
+index ef30bd4..1acc9d1 100644
+--- a/configdialog.cpp
++++ b/configdialog.cpp
+@@ -122,7 +122,7 @@ void ConfigDialog::browseAspell()
+ QDir spelldir(QCoreApplication::applicationDirPath());
+ #else
+ #ifdef DEBIAN_SPELLDIR
+-QDir spelldir(PREFIX"/share/myspell/dicts");
++QDir spelldir(PREFIX"/share/myspell");
+ #else
+ QDir spelldir(PREFIX"/share/texmaker");
+ #endif
+diff --git a/latexeditor.h b/latexeditor.h
+index b18ff9b..4fe11a0 100644
+--- a/latexeditor.h
++++ b/latexeditor.h
+@@ -26,7 +26,7 @@
+ #include <QTimer>
+
+ #include "latexhighlighter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ typedef int UserBookmarkList[3];
+
+diff --git a/latexeditorview.h b/latexeditorview.h
+index 0471d6f..f663fdf 100644
+--- a/latexeditorview.h
++++ b/latexeditorview.h
+@@ -19,7 +19,7 @@
+ #include "linenumberwidget.h"
+ #include "findwidget.h"
+ #include "minisplitter.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class LatexEditorView : public QWidget {
+ Q_OBJECT
+diff --git a/latexhighlighter.h b/latexhighlighter.h
+index 83ca79c..a1e437a 100644
+--- a/latexhighlighter.h
++++ b/latexhighlighter.h
+@@ -20,7 +20,7 @@
+ #include <QColor>
+ #include <QTextBlockUserData>
+ //#include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ class QTextDocument;
+ class LatexEditor;
+diff --git a/spellerdialog.h b/spellerdialog.h
+index 83248ae..cd16dad 100644
+--- a/spellerdialog.h
++++ b/spellerdialog.h
+@@ -13,7 +13,7 @@
+
+ #include "ui_spellerdialog.h"
+ #include "latexeditor.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+
+ #include <QTextCursor>
+
+diff --git a/texmaker.h b/texmaker.h
+index 8c98526..f9bbb1a 100644
+--- a/texmaker.h
++++ b/texmaker.h
+@@ -47,7 +47,7 @@
+ #include "logeditor.h"
+ #include "gotolinedialog.h"
+ #include "replacedialog.h"
+-#include "hunspell/hunspell.hxx"
++#include <hunspell.hxx>
+ #include "browser.h"
+ #include "pdfviewerwidget.h"
+ #include "pdfviewer.h"
+diff --git a/texmaker.pro b/texmaker.pro
+index 5647c49..08eeaf5 100644
+--- a/texmaker.pro
++++ b/texmaker.pro
+@@ -4,7 +4,8 @@ TARGET = texmaker
+ QT += network \
+ xml \
+ webkit
+-CONFIG += qt warn_off release
++CONFIG += qt warn_off release link_pkgconfig
++PKGCONFIG = hunspell
+ TEXMAKERVERSION=3.0.1
+ DEFINES += TEXMAKERVERSION=\\\"$${TEXMAKERVERSION}\\\"
+ DEFINES += HAVE_SPLASH
+@@ -56,25 +57,6 @@ HEADERS += texmaker.h \
+ usercompletiondialog.h \
+ synctex_parser.h \
+ synctex_parser_utils.h \
+- hunspell/affentry.hxx \
+- hunspell/affixmgr.hxx \
+- hunspell/atypes.hxx \
+- hunspell/baseaffix.hxx \
+- hunspell/csutil.hxx \
+- hunspell/dictmgr.hxx \
+- hunspell/hashmgr.hxx \
+- hunspell/htypes.hxx \
+- hunspell/hunspell.hxx \
+- hunspell/hunspell.h \
+- hunspell/langnum.hxx \
+- hunspell/license.hunspell \
+- hunspell/phonet.hxx \
+- hunspell/suggestmgr.hxx \
+- hunspell/license.myspell \
+- hunspell/filemgr.hxx \
+- hunspell/hunzip.hxx \
+- hunspell/replist.hxx \
+- hunspell/w_char.hxx \
+ singleapp/qtlocalpeer.h \
+ singleapp/qtlockedfile.h \
+ singleapp/qtsingleapplication.h \
+@@ -150,18 +132,6 @@ SOURCES += main.cpp \
+ usercompletiondialog.cpp \
+ synctex_parser.c \
+ synctex_parser_utils.c \
+- hunspell/affentry.cxx \
+- hunspell/affixmgr.cxx \
+- hunspell/csutil.cxx \
+- hunspell/dictmgr.cxx \
+- hunspell/hashmgr.cxx \
+- hunspell/hunspell.cxx \
+- hunspell/phonet.cxx \
+- hunspell/suggestmgr.cxx \
+- hunspell/utf_info.cxx \
+- hunspell/filemgr.cxx \
+- hunspell/replist.cxx \
+- hunspell/hunzip.cxx \
+ singleapp/qtlocalpeer.cpp \
+ singleapp/qtlockedfile.cpp \
+ singleapp/qtsingleapplication.cpp \
+@@ -253,7 +223,7 @@ LIBS += -L/usr/lib -lz
+ DEFINES += PREFIX=\\\"$${PREFIX}\\\"
+ target.path = $${PREFIX}/bin
+
+-#DEFINES += DEBIAN_SPELLDIR
++DEFINES += DEBIAN_SPELLDIR
+
+ INSTALLS = target
+ HEADERS += x11fontdialog.h
diff --git a/app-office/texmaker/metadata.xml b/app-office/texmaker/metadata.xml
index ba6a8a8800d5..4c15425c4724 100644
--- a/app-office/texmaker/metadata.xml
+++ b/app-office/texmaker/metadata.xml
@@ -2,4 +2,8 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>tex</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+<description>Heavily using the package</description>
+</maintainer>
</pkgmetadata>
diff --git a/app-office/texmaker/texmaker-3.01.ebuild b/app-office/texmaker/texmaker-3.01.ebuild
new file mode 100644
index 000000000000..9b21edae4734
--- /dev/null
+++ b/app-office/texmaker/texmaker-3.01.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmaker/texmaker-3.01.ebuild,v 1.1 2011/04/17 16:11:24 jlec Exp $
+
+EAPI="3"
+
+inherit base qt4-r2 versionator
+
+# The upstream version numbering is bad, so we have to remove a dot in the
+# minor version number
+MAJOR="$(get_major_version)"
+MINOR_1="$(($(get_version_component_range 2)/10))"
+MINOR_2="$(($(get_version_component_range 2)%10))"
+if [ ${MINOR_2} -eq "0" ] ; then
+ MY_P="${PN}-${MAJOR}.${MINOR_1}"
+else
+ MY_P="${PN}-${MAJOR}.${MINOR_1}.${MINOR_2}"
+fi
+
+DESCRIPTION="A nice LaTeX-IDE"
+HOMEPAGE="http://www.xm1math.net/texmaker/"
+SRC_URI="http://www.xm1math.net/texmaker/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+COMMON_DEPEND="
+ app-text/poppler[qt4]
+ x11-libs/libX11
+ x11-libs/libXext
+ >=x11-libs/qt-gui-4.6.1:4
+ >=x11-libs/qt-core-4.6.1:4
+ >=x11-libs/qt-webkit-4.6.1:4
+ >=app-text/hunspell-1.2.4"
+RDEPEND="${COMMON_DEPEND}
+ virtual/latex-base
+ app-text/psutils
+ app-text/ghostscript-gpl
+ media-libs/netpbm"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${P}-hunspell.patch" )
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ insinto /usr/share/pixmaps/texmaker
+ doins utilities/texmaker*.png || die "doins failed."
+ doins utilities/texmaker.svg || die "doins failed."
+
+ dodoc utilities/AUTHORS utilities/CHANGELOG.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "A user manual with many screenshots is available at:"
+ elog "/usr/share/${PN}/usermanual_en.html"
+}