summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/taskcoach/taskcoach-0.77.0.ebuild')
-rw-r--r--app-office/taskcoach/taskcoach-0.77.0.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/app-office/taskcoach/taskcoach-0.77.0.ebuild b/app-office/taskcoach/taskcoach-0.77.0.ebuild
new file mode 100644
index 000000000000..d8bd6cb6e92f
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-0.77.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.77.0.ebuild,v 1.1 2009/12/24 18:35:43 caster Exp $
+
+EAPI=1
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# disappeared in 0.73.2, maybe will appear again?
+#DOCS="CHANGES.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ if ! use x86; then
+ elog "Removing Funambol support, works only on x86."
+ rm -fv taskcoachlib/bin.in/linux/*.so || die
+ fi
+}
+
+src_compile() {
+ # upstream now sets executable to /usr/bin/python2.5
+ distutils_src_compile --executable=/usr/bin/python
+}
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}