summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice')
-rw-r--r--app-office/koffice/koffice-1.1.1.ebuild14
-rw-r--r--app-office/koffice/koffice-1.1.ebuild6
2 files changed, 10 insertions, 10 deletions
diff --git a/app-office/koffice/koffice-1.1.1.ebuild b/app-office/koffice/koffice-1.1.1.ebuild
index f4b027934685..aa0b0f5ddd52 100644
--- a/app-office/koffice/koffice-1.1.1.ebuild
+++ b/app-office/koffice/koffice-1.1.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Authors Dan Armak <danarmak@gentoo.org>, Bart Verwilst <verwilst@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.1.ebuild,v 1.4 2001/12/19 15:38:55 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.1.ebuild,v 1.5 2001/12/23 21:35:15 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
-need-kdelibs 2.2
+need-kde 2.2.2
DESCRIPTION="KDE ${PV} - KOffice"
@@ -28,25 +28,25 @@ src_unpack() {
}
src_compile() {
-
+
myconf="$myconf --enable-all"
kde_src_compile myconf
-
+
#the dir kchar/kdchart cannot be compiled with the -fomit-frame-pointer flag present
CXXFLAGS2="$CXXFLAGS"
CFLAGS2="$CFLAGS"
-
+
CFLAGS=${CFLAGS/-fomit-frame-pointer}
CXXFLAGS=${CXXFLAGS/-fomit-frame-pointer}
cd ${S}
kde_src_compile configure
cd ${S}/kchart/kdchart
make
-
+
CFLAGS="$CFLAGS2"
CXXFLAGS="$CXXFLAGS2"
cd ${S}
- kde_src_compile configure
+ kde_src_compile configure
make LIBPYTHON="`python-config --libs`"
}
diff --git a/app-office/koffice/koffice-1.1.ebuild b/app-office/koffice/koffice-1.1.ebuild
index 2b63e8f21148..462202a71176 100644
--- a/app-office/koffice/koffice-1.1.ebuild
+++ b/app-office/koffice/koffice-1.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Dan Armak <danarmak@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.ebuild,v 1.10 2001/12/08 17:27:11 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.1.ebuild,v 1.11 2001/12/23 21:35:15 danarmak Exp $
. /usr/portage/eclass/inherit.eclass || die
inherit kde-base || die
-need-kdelibs 2.2
+need-kde 2.2
DESCRIPTION="KDE ${PV} - KOffice"
@@ -34,4 +34,4 @@ src_compile() {
cd ${S}
make LIBPYTHON="`python-config --libs`"
-} \ No newline at end of file
+}