summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-office/koffice/koffice-1.3.3-r2.ebuild')
-rw-r--r--app-office/koffice/koffice-1.3.3-r2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-office/koffice/koffice-1.3.3-r2.ebuild b/app-office/koffice/koffice-1.3.3-r2.ebuild
new file mode 100644
index 000000000000..5f2f0d102c31
--- /dev/null
+++ b/app-office/koffice/koffice-1.3.3-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.3-r2.ebuild,v 1.1 2004/10/31 17:02:45 carlo Exp $
+
+inherit kde eutils
+
+# TODO : mysql support
+# other refs from configure: jasper, qt-docs, doxygen, libxml2, libxslt, freetype, fontconfig, qt being built with sql support (???)
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+SRC_URI="mirror://kde/stable/${P}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ~amd64 ~ppc ~sparc ~alpha ~ppc64"
+
+IUSE=""
+SLOT="0"
+
+DEPEND=">=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5
+ >=app-text/wv2-0.1.8
+ dev-util/pkgconfig"
+need-kde 3.1
+
+src_unpack() {
+ kde_src_unpack
+ epatch ${FILESDIR}/xpdf-CESA-2004-007-xpdf2-newer.diff
+ epatch ${FILESDIR}/koffice_1_3_4_xpdf_security_integer_overflow.diff
+}
+
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ use arts || DO_NOT_COMPILE="$DO_NOT_COMPILE kpresenter"
+ export DO_NOT_COMPILE="$DO_NOT_COMPILE"
+ kde_src_compile
+}