summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild')
-rw-r--r--app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild b/app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild
new file mode 100644
index 000000000000..bfd084cd2498
--- /dev/null
+++ b/app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/kmobiletools/kmobiletools-0.5_pre20060707.ebuild,v 1.1 2006/07/08 17:24:00 flameeyes Exp $
+
+inherit kde
+
+SVNDATE="${PV#*pre}"
+SVNNAME="svn-${SVNDATE:0:4}-${SVNDATE:4:2}-${SVNDATE:6:2}"
+
+DESCRIPTION="KMobiletools is a KDE-based application that allows to control mobile phones with your PC."
+SRC_URI="http://xoomer.virgilio.it/rockman81/kmobiletools/${PN}-${SVNNAME}.tar.bz2"
+HOMEPAGE="http://www.kmobiletools.org/"
+LICENSE="GPL-2"
+
+IUSE="kde"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="kde? ( kde-base/libkcal
+ kde-base/kontact )"
+
+S="${WORKDIR}/svn-${PN}"
+
+need-kde 3.3
+
+src_compile() {
+ myconf="${myconf} $(use_enable kde libkcal)
+ $(use_enable kde kontact-plugin)"
+
+ kde_src_compile
+}
+