summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-mobilephone/anyremote/anyremote-5.4.ebuild')
-rw-r--r--app-mobilephone/anyremote/anyremote-5.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-mobilephone/anyremote/anyremote-5.4.ebuild b/app-mobilephone/anyremote/anyremote-5.4.ebuild
new file mode 100644
index 000000000000..a32a02027af9
--- /dev/null
+++ b/app-mobilephone/anyremote/anyremote-5.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-mobilephone/anyremote/anyremote-5.4.ebuild,v 1.1 2011/02/13 21:07:11 serkan Exp $
+
+EAPI="2"
+
+DESCRIPTION="Anyremote provides wireless bluetooth, infrared or cable remote control service"
+HOMEPAGE="http://anyremote.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bluetooth dbus"
+
+RDEPEND="bluetooth? ( net-wireless/bluez )
+ dbus? ( sys-apps/dbus )
+ x11-libs/libXtst"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf --docdir="/usr/share/doc/${PF}/" $(use_enable bluetooth) $(use_enable dbus)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "install doc failed"
+}