summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/gramps/ChangeLog7
-rw-r--r--app-misc/gramps/gramps-3.0.4.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-misc/gramps/ChangeLog b/app-misc/gramps/ChangeLog
index 23c14b6697e2..3723a8850427 100644
--- a/app-misc/gramps/ChangeLog
+++ b/app-misc/gramps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/gramps
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.84 2008/12/22 12:41:35 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/ChangeLog,v 1.85 2008/12/22 12:46:58 fauli Exp $
+
+*gramps-3.0.4 (22 Dec 2008)
+
+ 22 Dec 2008; Christian Faulhammer <fauli@gentoo.org> +gramps-3.0.4.ebuild:
+ version bump: Bugfix and translation update release
22 Dec 2008; Christian Faulhammer <fauli@gentoo.org>
+files/gramps-3.0.3_fix-installation-race-condition.patch,
diff --git a/app-misc/gramps/gramps-3.0.4.ebuild b/app-misc/gramps/gramps-3.0.4.ebuild
new file mode 100644
index 000000000000..5c789ff15993
--- /dev/null
+++ b/app-misc/gramps/gramps-3.0.4.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/gramps/gramps-3.0.4.ebuild,v 1.1 2008/12/22 12:46:58 fauli Exp $
+
+NEED_PYTHON="2.5"
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools eutils gnome2 python
+
+DESCRIPTION="Genealogical Research and Analysis Management Programming System"
+HOMEPAGE="http://www.gramps-project.org/"
+SRC_URI="mirror://sourceforge/gramps/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="gnome reports"
+
+RDEPEND=">=dev-python/pygtk-2.10.0
+ gnome? ( || ( dev-python/libgnome-python
+ >=dev-python/gnome-python-2.22.0
+ >=dev-python/gnome-python-desktop-2.6 ) )
+ reports? ( media-gfx/graphviz )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/libiconv
+ dev-util/pkgconfig
+ app-text/gnome-doc-utils"
+
+DOCS="NEWS README TODO"
+
+pkg_setup() {
+ if ! built_with_use -a 'dev-lang/python' sqlite berkdb ; then
+ eerror "You need to install python with Berkeley Database support."
+ eerror "Add 'dev-lang/python berkdb sqlite' to /etc/portage/package.use "
+ eerror "and then re-emerge python."
+ die "berkdb or sqlite support missing from Python"
+ fi
+
+ G2CONF="${G2CONF} --disable-mime-install"
+}
+
+src_unpack() {
+ gnome2_src_unpack
+ epatch "${FILESDIR}"/${PN}-3.0.3_fix-installation-race-condition.patch
+ eautoreconf
+ # This is for bug 215944, so .pyo/.pyc files don't get into the
+ # file system
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+}
+
+src_install() {
+ python_need_rebuild
+ gnome2_src_install
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_mod_optimize /usr/share/${PN}
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_mod_cleanup /usr/share/${PN}
+}