summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/when/when-1.1.16.ebuild')
-rw-r--r--app-misc/when/when-1.1.16.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/when/when-1.1.16.ebuild b/app-misc/when/when-1.1.16.ebuild
new file mode 100644
index 000000000000..36bfcccf8491
--- /dev/null
+++ b/app-misc/when/when-1.1.16.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/when/when-1.1.16.ebuild,v 1.1 2009/01/26 20:24:07 pva Exp $
+
+DESCRIPTION="Extremely simple personal calendar program aimed at the Unix geek who wants something minimalistic"
+HOMEPAGE="http://www.lightandmatter.com/when/when.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/when_dist
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix path for tests
+ sed -i 's,^ when, ./when,' Makefile
+}
+
+src_compile() {
+ return
+}
+
+src_test() {
+ # The when command requires these files, or attempts to run setup function.
+ mkdir "${HOME}"/.when
+ touch "${HOME}"/.when/{calendar,preferences}
+ emake test || die "emake test failed"
+}
+
+src_install() {
+ dobin ${PN} || die "dobin failed"
+ doman ${PN}.1 || die "doman failed"
+ dodoc README
+}