summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/gentoo/gentoo-0.19.10.ebuild')
-rw-r--r--app-misc/gentoo/gentoo-0.19.10.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/app-misc/gentoo/gentoo-0.19.10.ebuild b/app-misc/gentoo/gentoo-0.19.10.ebuild
deleted file mode 100644
index d0c587009a53..000000000000
--- a/app-misc/gentoo/gentoo-0.19.10.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/gentoo/gentoo-0.19.10.ebuild,v 1.7 2011/11/07 00:30:24 ranger Exp $
-
-EAPI=4
-
-inherit autotools eutils
-
-DESCRIPTION="A modern GTK+ based filemanager for any WM"
-HOMEPAGE="http://www.obsession.se/gentoo/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 hppa ia64 ppc ~ppc64 sparc x86"
-IUSE="nls"
-
-RDEPEND=">=x11-libs/gtk+-2.24:2
- dev-libs/glib:2
- x11-libs/gdk-pixbuf
- x11-libs/pango"
-DEPEND="${RDEPEND}
- nls? ( sys-devel/gettext )"
-
-src_prepare() {
- sed -i \
- -e 's^icons/gnome/16x16/mimetypes^gentoo/icons^' \
- gentoorc.in || die "Fixing icon path failed."
- sed -i \
- -e '/GTK_DISABLE_DEPRECATED/ d' \
- -e '/^GENTOO_CFLAGS=/s|".*"|"${CFLAGS}"|g' \
- configure.in || die "Fixing configure.in failed" #357343
- eautoreconf
-}
-
-src_configure() {
- econf \
- --disable-dependency-tracking \
- --sysconfdir=/etc/gentoo \
- $(use_enable nls)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc AUTHORS BUGS CONFIG-CHANGES CREDITS NEWS \
- README TODO docs/{FAQ,menus.txt}
- dohtml -r docs/{images,config,*.{html,css}}
- newman docs/gentoo.1x gentoo.1
- docinto scratch
- dodoc docs/scratch/*
-
- make_desktop_entry ${PN} Gentoo \
- /usr/share/${PN}/icons/${PN}.png \
- "System;FileTools;FileManager"
-}