summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/devtodo/devtodo-0.1.19.ebuild')
-rw-r--r--app-misc/devtodo/devtodo-0.1.19.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/app-misc/devtodo/devtodo-0.1.19.ebuild b/app-misc/devtodo/devtodo-0.1.19.ebuild
deleted file mode 100644
index 2583cff80807..000000000000
--- a/app-misc/devtodo/devtodo-0.1.19.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.19.ebuild,v 1.11 2007/01/28 05:06:50 genone Exp $
-
-inherit eutils bash-completion flag-o-matic
-
-DESCRIPTION="A nice command line todo list for developers"
-HOMEPAGE="http://swapoff.org/DevTodo"
-SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sparc x86"
-IUSE=""
-
-RDEPEND=">=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-0.1.18-gcc4.diff
- epatch ${FILESDIR}/${P}-gentoo.diff
-}
-
-src_compile() {
- einfo "Running autoreconf"
- autoreconf -f -i || die "autoreconf failed"
- replace-flags -O[23] -O1
- econf --sysconfdir=/etc/devtodo || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog QuickStart README doc/scripts.sh \
- doc/scripts.tcsh doc/todorc.example || die "dodoc failed"
-
- dobashcompletion contrib/${PN}.bash-completion ${PN}
- rm contrib/${PN}.bash-completion
- docinto contrib
- dodoc contrib/*
-}
-
-pkg_postinst() {
- echo
- elog "Because of a conflict with app-misc/tdl, the tdl symbolic link"
- elog "and manual page have been removed."
- bash-completion_pkg_postinst
-}