summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/chesstask/chesstask-2.0.ebuild')
-rw-r--r--app-misc/chesstask/chesstask-2.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/chesstask/chesstask-2.0.ebuild b/app-misc/chesstask/chesstask-2.0.ebuild
new file mode 100644
index 000000000000..0cf39139c826
--- /dev/null
+++ b/app-misc/chesstask/chesstask-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/chesstask/chesstask-2.0.ebuild,v 1.1 2004/06/27 19:20:37 usata Exp $
+
+IUSE=""
+
+S=${WORKDIR}/ChessTask
+DESCRIPTION="An editor for chess problems. It will generate PostScript and HTML files."
+HOMEPAGE="http://chesstask.sourceforge.net/"
+SRC_URI="mirror://sourceforge/chesstask/ChessTask${PV/./_}src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND=">=x11-libs/qt-3
+ virtual/tetex"
+
+src_compile() {
+ sed -i -e "/ENGLISH/s/^#//" ChessTask.pro || die
+ qmake -o Makefile ChessTask.pro || die
+ emake || die "compile failed"
+}
+
+src_install() {
+ dobin ChessTask
+
+ dodoc HISTORY LIESMICH README
+}