summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-misc/abook/abook-0.5.5.ebuild')
-rw-r--r--app-misc/abook/abook-0.5.5.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-misc/abook/abook-0.5.5.ebuild b/app-misc/abook/abook-0.5.5.ebuild
new file mode 100644
index 000000000000..15ba6eeefc2c
--- /dev/null
+++ b/app-misc/abook/abook-0.5.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/abook/abook-0.5.5.ebuild,v 1.1 2005/12/02 15:56:25 rizzo Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="Abook is a text-based addressbook program designed to use with mutt mail client."
+HOMEPAGE="http://abook.sourceforge.net/"
+SRC_URI="mirror://sourceforge/abook/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses
+ sys-libs/readline"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ gnuconfig_update
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "install died"
+ dodoc ANNOUNCE AUTHORS BUGS ChangeLog FAQ NEWS README THANKS TODO
+ dodoc sample.abookrc
+}