summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-laptop/omnibook/omnibook-20060126.ebuild')
-rw-r--r--app-laptop/omnibook/omnibook-20060126.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/app-laptop/omnibook/omnibook-20060126.ebuild b/app-laptop/omnibook/omnibook-20060126.ebuild
new file mode 100644
index 000000000000..26246bf6723f
--- /dev/null
+++ b/app-laptop/omnibook/omnibook-20060126.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-laptop/omnibook/omnibook-20060126.ebuild,v 1.1 2006/03/02 01:30:12 genstef Exp $
+
+inherit linux-mod eutils
+
+
+DESCRIPTION="Linux kernel module for (but not limited to) HP Omnibook support"
+HOMEPAGE="http://www.sourceforge.net/projects/omke"
+SRC_URI="mirror://sourceforge/omke/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~x86 -ppc"
+IUSE=""
+
+MODULE_NAMES="omnibook(char:)"
+BUILD_TARGETS=" "
+
+pkg_setup() {
+ linux-mod_pkg_setup
+ BUILD_PARAMS="KERNEL=${KV_MAJOR}.${KV_MINOR} KSRC=${KV_DIR}"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/omnibook-fix-obtest-segfault.patch
+ epatch ${FILESDIR}/remove-legacy-isa-fromio.patch
+ convert_to_m Makefile
+}
+
+src_compile() {
+ cd misc/obtest
+ emake || die "make obtest failed"
+
+ linux-mod_src_compile
+}
+
+src_install() {
+ dosbin misc/obtest/obtest
+ dodoc doc/*
+ docinto misc
+ dodoc misc/*.patch misc/*.txt
+ docinto hotkeys
+ dodoc misc/hotkeys/*
+
+ linux-mod_src_install
+}