summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-forensics/openscap')
-rw-r--r--app-forensics/openscap/ChangeLog9
-rw-r--r--app-forensics/openscap/files/test_probes_process.patch2
-rw-r--r--app-forensics/openscap/metadata.xml7
-rw-r--r--app-forensics/openscap/openscap-0.8.0.ebuild84
-rw-r--r--app-forensics/openscap/openscap-0.9.1.ebuild (renamed from app-forensics/openscap/openscap-0.8.2.ebuild)26
5 files changed, 28 insertions, 100 deletions
diff --git a/app-forensics/openscap/ChangeLog b/app-forensics/openscap/ChangeLog
index a64cbc0f653c..2d104161ae0f 100644
--- a/app-forensics/openscap/ChangeLog
+++ b/app-forensics/openscap/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-forensics/openscap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.18 2012/08/01 13:34:25 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/ChangeLog,v 1.19 2012/10/25 17:16:04 hwoarang Exp $
+
+*openscap-0.9.1 (25 Oct 2012)
+
+ 25 Oct 2012; Markos Chandras <hwoarang@gentoo.org> +openscap-0.9.1.ebuild,
+ -openscap-0.8.0.ebuild, -openscap-0.8.2.ebuild,
+ files/test_probes_process.patch, metadata.xml:
+ Version bump. Thanks to LABBE Corentin (Montjoie)
*openscap-0.8.3 (01 Aug 2012)
diff --git a/app-forensics/openscap/files/test_probes_process.patch b/app-forensics/openscap/files/test_probes_process.patch
index 508c059e2a77..b9c1c3a64b45 100644
--- a/app-forensics/openscap/files/test_probes_process.patch
+++ b/app-forensics/openscap/files/test_probes_process.patch
@@ -4,7 +4,7 @@
#!/usr/bin/env bash
-TMP_P=(`LD_PRELOAD= ps -A -o pid -o ppid -o comm | awk '$1 != 2 && $2 != 2 {print $3}' | \
-+TMP_P=(`LD_PRELOAD= ps -A -o pid -o ppid -o comm | grep -iE '^[a-z0-9A-Z \-]*$' | awk '$1 != 2 && $2 != 2 {print $3}' | \
++TMP_P=(`LD_PRELOAD= ps -A -o pid -o ppid -o comm | grep -iE '^[a-z0-9A-Z \-]*$' |grep -vE 'cron|grep' | awk '$1 != 2 && $2 != 2 {print $3}' | \
sed -n '2,30p'`)
COUNTER=1
diff --git a/app-forensics/openscap/metadata.xml b/app-forensics/openscap/metadata.xml
index 8be2af1a9c36..889e265b225d 100644
--- a/app-forensics/openscap/metadata.xml
+++ b/app-forensics/openscap/metadata.xml
@@ -5,12 +5,7 @@
<maintainer>
<email>corentin.labbe@geomatys.fr</email>
<name>LABBE Corentin (Montjoie)</name>
-<description>Maintainer.</description>
-</maintainer>
-<maintainer>
-<email>hwoarang@gentoo.org</email>
-<name>Markos Chandras</name>
-<description>Proxy maintainer.</description>
+<description>Maintainer</description>
</maintainer>
<use>
<flag name="nss">Prefer NSS over libgcrypt as the crypto engine</flag>
diff --git a/app-forensics/openscap/openscap-0.8.0.ebuild b/app-forensics/openscap/openscap-0.8.0.ebuild
deleted file mode 100644
index df2a7435c2c9..000000000000
--- a/app-forensics/openscap/openscap-0.8.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.8.0.ebuild,v 1.2 2011/12/28 14:01:19 swift Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="2"
-
-inherit eutils multilib python bash-completion-r1
-
-DESCRIPTION="Framework which enables integration with the Security Content Automation Protocol (SCAP)"
-HOMEPAGE="http://www.open-scap.org/"
-SRC_URI="http://www.open-scap.org/download/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="bash-completion doc nss perl python rpm sql"
-RESTRICT="test"
-
-RDEPEND="!nss? ( dev-libs/libgcrypt )
- nss? ( dev-libs/nss )
- rpm? ( >=app-arch/rpm-4.9 )
- sql? ( dev-db/opendbx )
- dev-libs/libpcre
- dev-libs/libxml2
- dev-libs/libxslt
- net-misc/curl"
-DEPEND="${RDEPEND}
- perl? ( dev-lang/swig )
- python? ( dev-lang/swig )"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
- sed -i 's,/etc/rc.d/init.d,/etc/init.d,' src/OVAL/probes/unix/runlevel.c || die
- if ! use rpm ; then
- sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
- sed -i 's,probe_rpminfo_opt_deps_ok=yes,probe_rpminfo_opt_deps_ok=no,' configure || die
- sed -i 's,probe_rpmverify_req_deps_ok=yes,probe_rpmverify_req_deps_ok=no,' configure || die
- sed -i 's,probe_rpmverify_opt_deps_ok=yes,probe_rpmverify_opt_deps_ok=no,' configure || die
- sed -i 's,^probe_rpm.*_deps_missing=,&disabled by USE flag,' configure || die
- fi
-}
-
-src_configure() {
- local myconf
- if use python || use perl ; then
- myconf+=" --enable-bindings"
- else
- myconf+=" --disable-bindings"
- fi
- if use nss ; then
- myconf+=" --with-crypto=nss3"
- else
- myconf+=" --with-crypto=gcrypt"
- fi
- econf ${myconf}
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die
- find "${D}" -name '*.la' -delete || die
- sed -i 's/^Description/&:/' "${D}"/usr/$(get_libdir)/pkgconfig/libopenscap.pc || die
- #--enable-bindings enable all bindings, clean unwanted bindings
- if use python && ! use perl ; then
- rm -rf "${D}"/usr/$(get_libdir)/perl5 || die
- fi
- if ! use python && use perl ; then
- rm -rf "${D}"/$(python_get_sitedir) || die
- fi
- if use doc ; then
- dohtml -r docs/html/* || die
- dodoc docs/examples/* || die
- fi
- if use bash-completion ; then
- dobashcomp "${D}"/etc/bash_completion.d/oscap
- fi
- rm -rf "${D}"/etc/bash_completion.d || die
-}
diff --git a/app-forensics/openscap/openscap-0.8.2.ebuild b/app-forensics/openscap/openscap-0.9.1.ebuild
index 7bb3862d272f..600b216c48c4 100644
--- a/app-forensics/openscap/openscap-0.8.2.ebuild
+++ b/app-forensics/openscap/openscap-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.8.2.ebuild,v 1.1 2012/05/22 20:51:55 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/openscap/openscap-0.9.1.ebuild,v 1.1 2012/10/25 17:16:04 hwoarang Exp $
EAPI=3
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
test? (
app-arch/unzip
+ dev-perl/XML-XPath
net-misc/ipcalc
sys-apps/grep )"
@@ -41,18 +42,25 @@ pkg_setup() {
src_prepare() {
sed -i 's/uname -p/uname -m/' tests/probes/uname/test_probes_uname.xml.sh || die
- sed -i 's,/etc/rc.d/init.d,/etc/init.d,' src/OVAL/probes/unix/runlevel.c || die
- #problem sent upstream https://fedorahosted.org/openscap/ticket/45
- sed -i 's,unzip,\$1,' tests/test_common.sh || die
- #problem sent upstream https://fedorahosted.org/openscap/ticket/46
- epatch ${FILESDIR}/test_probes_interface.patch || die
- # runlevel isnt supported on gentoo
+
+ #probe runlevel for non-centos/redhat/fedora is not implemted
+ sed -i 's,.*runlevel_test,#&,' tests/mitre/test_mitre.sh || die
sed -i 's,probecheck "runlevel,probecheck "runlevellllll,' tests/probes/runlevel/test_probes_runlevel.sh || die
+
#According to comment of theses tests, we must modify it. For the moment disable it
sed -i 's,.*linux-def_inetlisteningservers_test,#&,' tests/mitre/test_mitre.sh || die
sed -i 's,.*ind-def_environmentvariable_test,#&,' tests/mitre/test_mitre.sh || die
+
#This test fail when testing process with [] in names https://fedorahosted.org/openscap/ticket/47
- epatch ${FILESDIR}/test_probes_process.patch || die
+ epatch "${FILESDIR}"/test_probes_process.patch || die
+
+ # theses tests are hardcoded for checking hald process...,
+ # but no good solution for the moment, disabling them with a fake echo
+ # because encased in a if then
+# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process_test.xml || die
+# sed -i 's,ha.d,/sbin/udevd --daemon,g' tests/mitre/unix-def_process58_test.xml || die
+ sed -i 's,.*process_test.*,echo "",' tests/mitre/test_mitre.sh || die
+ sed -i 's,.*process58_test.*,echo "",' tests/mitre/test_mitre.sh || die
if ! use rpm ; then
sed -i 's,probe_rpminfo_req_deps_ok=yes,probe_rpminfo_req_deps_ok=no,' configure || die
@@ -64,6 +72,8 @@ src_prepare() {
fi
if ! use selinux ; then
sed -i 's,.*selinux.*,#&,' tests/mitre/test_mitre.sh || die
+ #process58 need selinux
+ sed -i 's,.*process58,#&,' tests/mitre/test_mitre.sh || die
fi
}