summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine/wine-1.7.29.ebuild')
-rw-r--r--app-emulation/wine/wine-1.7.29.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-emulation/wine/wine-1.7.29.ebuild b/app-emulation/wine/wine-1.7.29.ebuild
index 021ef9048c67..6594da7ef5bd 100644
--- a/app-emulation/wine/wine-1.7.29.ebuild
+++ b/app-emulation/wine/wine-1.7.29.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.29.ebuild,v 1.2 2015/01/01 21:01:23 ryao Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/wine/wine-1.7.29.ebuild,v 1.3 2015/03/08 07:00:24 tetromino Exp $
EAPI="5"
@@ -26,6 +26,7 @@ GV="2.24"
MV="4.5.2"
COMPHOLIO_P="wine-staging-${PV}"
WINE_GENTOO="wine-gentoo-2013.06.24"
+GST_P="wine-1.7.28-gstreamer-v4"
DESCRIPTION="Free implementation of Windows(tm) on Unix"
HOMEPAGE="http://www.winehq.org/"
SRC_URI="${SRC_URI}
@@ -36,6 +37,7 @@ SRC_URI="${SRC_URI}
mono? ( mirror://sourceforge/${PN}/Wine%20Mono/${MV}/wine-mono-${MV}.msi )
pipelight? ( https://github.com/wine-compholio/wine-staging/archive/v${PV}.tar.gz -> ${COMPHOLIO_P}.tar.gz )
pulseaudio? ( https://github.com/wine-compholio/wine-staging/archive/v${PV}.tar.gz -> ${COMPHOLIO_P}.tar.gz )
+ gstreamer? ( http://dev.gentoo.org/~tetromino/distfiles/${PN}/${GST_P}.patch.bz2 )
http://dev.gentoo.org/~tetromino/distfiles/${PN}/${WINE_GENTOO}.tar.bz2"
LICENSE="LGPL-2.1"
@@ -294,6 +296,7 @@ src_unpack() {
use pipelight || use pulseaudio && unpack "${COMPHOLIO_P}.tar.gz"
unpack "${WINE_GENTOO}.tar.bz2"
+ use gstreamer && unpack "${GST_P}.patch.bz2"
l10n_find_plocales_changes "${S}/po" "" ".po"
}
@@ -315,7 +318,7 @@ src_prepare() {
ewarn "Applying experimental patch to fix GStreamer support. Note that"
ewarn "this patch has been reported to cause crashes in certain games."
- PATCHES+=( "${FILESDIR}/${PN}-1.7.28-gstreamer-v4.patch" )
+ PATCHES+=( "${WORKDIR}/${GST_P}.patch" )
fi
if use pipelight; then
ewarn "Applying the unofficial Compholio patchset for Pipelight support,"