summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/libspectrum/libspectrum-0.2.1.ebuild')
-rw-r--r--app-emulation/libspectrum/libspectrum-0.2.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-emulation/libspectrum/libspectrum-0.2.1.ebuild b/app-emulation/libspectrum/libspectrum-0.2.1.ebuild
new file mode 100644
index 000000000000..2854717438e4
--- /dev/null
+++ b/app-emulation/libspectrum/libspectrum-0.2.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/libspectrum/libspectrum-0.2.1.ebuild,v 1.1 2004/02/28 07:25:54 vapier Exp $
+
+DESCRIPTION="Spectrum emulation library"
+HOMEPAGE="http://fuse-emulator.sourceforge.net/libspectrum.php"
+SRC_URI="mirror://sourceforge/fuse-emulator/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+DEPEND="=dev-libs/glib-1*
+ >=dev-libs/libgcrypt-1.1.91
+ dev-lang/perl"
+
+src_compile() {
+ econf --with-glib || die
+ emake -j1 || die "libspectrum make failed!"
+}
+
+src_install() {
+ emake install DESTDIR=${D} || die
+ dodoc AUTHORS ChangeLog README THANKS doc/*.txt *.txt
+}