summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/org-mode')
-rw-r--r--app-emacs/org-mode/ChangeLog10
-rw-r--r--app-emacs/org-mode/files/51org-mode-gentoo.el2
-rw-r--r--app-emacs/org-mode/files/digest-org-mode-4.743
-rw-r--r--app-emacs/org-mode/org-mode-4.74.ebuild30
4 files changed, 43 insertions, 2 deletions
diff --git a/app-emacs/org-mode/ChangeLog b/app-emacs/org-mode/ChangeLog
index 8b5ed9411d9f..a56c8071c9ba 100644
--- a/app-emacs/org-mode/ChangeLog
+++ b/app-emacs/org-mode/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-emacs/org-mode
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.4 2007/04/10 19:43:12 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/ChangeLog,v 1.5 2007/05/16 15:05:14 ulm Exp $
+
+*org-mode-4.74 (16 May 2007)
+
+ 16 May 2007; Ulrich Mueller <ulm@gentoo.org> files/51org-mode-gentoo.el,
+ +org-mode-4.74.ebuild:
+ Version bump. Install some documentation. Dropped ~ppc-macos keyword.
+ Activate auto-mode for .org files, as suggested by MATSUYAMA Tomohiro
+ <matsuyama@ariel-networks.com> in bug #178770.
10 Apr 2007; Christian Faulhammer <opfer@gentoo.org> org-mode-4.68.ebuild:
added FDL license
diff --git a/app-emacs/org-mode/files/51org-mode-gentoo.el b/app-emacs/org-mode/files/51org-mode-gentoo.el
index 541275efabdf..bebeec962052 100644
--- a/app-emacs/org-mode/files/51org-mode-gentoo.el
+++ b/app-emacs/org-mode/files/51org-mode-gentoo.el
@@ -1,5 +1,5 @@
;;; org-mode site-lisp configuration
(add-to-list 'load-path "@SITELISP@")
+(add-to-list 'auto-mode-alist '("\\.org\\'" . org-mode))
(require 'org-install)
-
diff --git a/app-emacs/org-mode/files/digest-org-mode-4.74 b/app-emacs/org-mode/files/digest-org-mode-4.74
new file mode 100644
index 000000000000..f29536403adc
--- /dev/null
+++ b/app-emacs/org-mode/files/digest-org-mode-4.74
@@ -0,0 +1,3 @@
+MD5 7a2f480db97f5257cfbf0bd982582bf9 org-4.74.tar.gz 977485
+RMD160 ca527af86089605ed5fcaa19730393b63eaba5ac org-4.74.tar.gz 977485
+SHA256 0b1979e206a2b5171ecc1c86fa9a2d9c6d3aa59e1a9e8c0b221d9d3b6364e1ce org-4.74.tar.gz 977485
diff --git a/app-emacs/org-mode/org-mode-4.74.ebuild b/app-emacs/org-mode/org-mode-4.74.ebuild
new file mode 100644
index 000000000000..becca84fdec9
--- /dev/null
+++ b/app-emacs/org-mode/org-mode-4.74.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/org-mode/org-mode-4.74.ebuild,v 1.1 2007/05/16 15:05:14 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="An Emacs mode for notes and project planning"
+HOMEPAGE="http://staff.science.uva.nl/~dominik/Tools/org/"
+SRC_URI="http://staff.science.uva.nl/~dominik/Tools/org/org-${PV}.tar.gz"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+SITEFILE="51${PN}-gentoo.el"
+
+S="${WORKDIR}/org-${PV}"
+
+src_compile() {
+ elisp_src_compile
+ emake info || die "emake info failed"
+ mv org org.info || die "Infofile could not be renamed"
+}
+
+src_install() {
+ elisp_src_install
+ doinfo *.info
+ dodoc README org.pdf orgcard.pdf || die "dodoc failed"
+}