summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emacs/chess')
-rw-r--r--app-emacs/chess/ChangeLog13
-rw-r--r--app-emacs/chess/chess-2.0_beta5-r4.ebuild (renamed from app-emacs/chess/chess-2.0_beta5-r3.ebuild)26
-rw-r--r--app-emacs/chess/chess-2.0_beta6.ebuild48
-rw-r--r--app-emacs/chess/files/2.0_beta6-chess-pos-move-gentoo.patch12
-rw-r--r--app-emacs/chess/files/digest-chess-2.0_beta5-r4 (renamed from app-emacs/chess/files/digest-chess-2.0_beta5-r3)0
-rw-r--r--app-emacs/chess/files/digest-chess-2.0_beta69
6 files changed, 92 insertions, 16 deletions
diff --git a/app-emacs/chess/ChangeLog b/app-emacs/chess/ChangeLog
index bef9f77ba08e..687be2099115 100644
--- a/app-emacs/chess/ChangeLog
+++ b/app-emacs/chess/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-emacs/chess
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.14 2007/09/23 12:38:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/ChangeLog,v 1.15 2007/09/24 10:30:11 ulm Exp $
+
+*chess-2.0_beta6 (24 Sep 2007)
+*chess-2.0_beta5-r4 (24 Sep 2007)
+
+ 24 Sep 2007; Ulrich Mueller <ulm@gentoo.org>
+ +files/2.0_beta6-chess-pos-move-gentoo.patch, -chess-2.0_beta5-r3.ebuild,
+ +chess-2.0_beta5-r4.ebuild, +chess-2.0_beta6.ebuild:
+ Version bump. 2.0_beta6 compiles and runs with both Emacs 21 and 22 now.
+ Fix assert problem in chess-pos-move that occured for the start position.
+ Remove festival USE flag since it changes nothing for the installed package.
+ Install pixmap files in correct location.
23 Sep 2007; Ulrich Mueller <ulm@gentoo.org> -chess-2.0_beta5-r1.ebuild,
chess-2.0_beta5-r3.ebuild:
diff --git a/app-emacs/chess/chess-2.0_beta5-r3.ebuild b/app-emacs/chess/chess-2.0_beta5-r4.ebuild
index 57077aacf181..4006c1200d5d 100644
--- a/app-emacs/chess/chess-2.0_beta5-r3.ebuild
+++ b/app-emacs/chess/chess-2.0_beta5-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta5-r3.ebuild,v 1.2 2007/09/23 12:38:25 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta5-r4.ebuild,v 1.1 2007/09/24 10:30:11 ulm Exp $
NEED_EMACS=22
@@ -15,41 +15,37 @@ SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.bz2
LICENSE="GPL-2 FDL-1.1"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="festival"
+IUSE=""
DEPEND=""
-
-RDEPEND="${DEPEND}
- games-board/gnuchess
- festival? ( app-accessibility/festival ) "
+RDEPEND="games-board/gnuchess"
S="${WORKDIR}/${P/_beta/b}"
SITEFILE=51${PN}-gentoo.el
+DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
src_unpack() {
unpack ${A}
+ cd "${S}"
epatch "${FILESDIR}/${PV}-byte-compiling-files-gentoo.patch" \
|| die "epatch failed"
- cd "${S}" && rm -f *.elc
+ rm -f *.elc
}
+# this is needed; elisp.eclass redefines src_compile() from portage default
src_compile() {
emake || die "emake failed"
}
src_install() {
- elisp-install ${PN} *.el *.elc
- elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ elisp_src_install
+ doinfo chess.info
einfo "Installing sound files ..."
insinto /usr/share/sounds/${PN}
doins "${WORKDIR}"/sounds/*
- einfo "Installing graphic files ..."
- insinto /usr/share/pixmaps/
+ einfo "Installing pixmap files ..."
+ insinto /usr/share/pixmaps/${PN}
doins -r "${WORKDIR}"/pieces/*
- einfo "Installing documentation ..."
- doinfo chess.info
- dohtml *.html
- dodoc ChangeLog EPD.txt PGN.txt PLAN README TODO
}
diff --git a/app-emacs/chess/chess-2.0_beta6.ebuild b/app-emacs/chess/chess-2.0_beta6.ebuild
new file mode 100644
index 000000000000..372c39cc3f4b
--- /dev/null
+++ b/app-emacs/chess/chess-2.0_beta6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/chess/chess-2.0_beta6.ebuild,v 1.1 2007/09/24 10:30:11 ulm Exp $
+
+inherit elisp eutils
+
+DESCRIPTION="A chess client and library for Emacs"
+HOMEPAGE="http://emacs-chess.sourceforge.net/"
+SRC_URI="mirror://sourceforge/emacs-chess/${P/_beta/b}.tar.gz
+ mirror://gentoo/emacs-chess-sounds-2.0.tar.bz2
+ mirror://gentoo/emacs-chess-pieces-2.0.tar.bz2"
+
+LICENSE="GPL-2 FDL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="games-board/gnuchess"
+
+S="${WORKDIR}/${PN}"
+
+SITEFILE=51${PN}-gentoo.el
+DOCS="ChangeLog EPD.txt PGN.txt PLAN README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-chess-pos-move-gentoo.patch" \
+ || die "epatch failed"
+}
+
+# this is needed; elisp.eclass redefines src_compile() from portage default
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ elisp_src_install
+
+ doinfo chess.info
+ einfo "Installing sound files ..."
+ insinto /usr/share/sounds/${PN}
+ doins "${WORKDIR}"/sounds/*
+ einfo "Installing pixmap files ..."
+ insinto /usr/share/pixmaps/${PN}
+ doins -r "${WORKDIR}"/pieces/*
+}
diff --git a/app-emacs/chess/files/2.0_beta6-chess-pos-move-gentoo.patch b/app-emacs/chess/files/2.0_beta6-chess-pos-move-gentoo.patch
new file mode 100644
index 000000000000..fe7a31ba1222
--- /dev/null
+++ b/app-emacs/chess/files/2.0_beta6-chess-pos-move-gentoo.patch
@@ -0,0 +1,12 @@
+--- chess-orig/chess-pos.el 2004-02-18 18:53:26.000000000 +0100
++++ chess/chess-pos.el 2007-09-24 11:04:39.000000000 +0200
+@@ -595,7 +595,8 @@
+ trying to move a blank square."
+ (assert (vectorp position))
+ (assert (listp changes))
+- (assert (> (length changes) 0))
++ ;; this fails for the start position in chess-opening
++ ;;(assert (> (length changes) 0))
+
+ ;; apply the piece movements listed in `changes'
+ (let ((ch changes))
diff --git a/app-emacs/chess/files/digest-chess-2.0_beta5-r3 b/app-emacs/chess/files/digest-chess-2.0_beta5-r4
index 253a6c1245f9..253a6c1245f9 100644
--- a/app-emacs/chess/files/digest-chess-2.0_beta5-r3
+++ b/app-emacs/chess/files/digest-chess-2.0_beta5-r4
diff --git a/app-emacs/chess/files/digest-chess-2.0_beta6 b/app-emacs/chess/files/digest-chess-2.0_beta6
new file mode 100644
index 000000000000..3f6e668bca74
--- /dev/null
+++ b/app-emacs/chess/files/digest-chess-2.0_beta6
@@ -0,0 +1,9 @@
+MD5 3222239cc7c3e664a9dcb47a12f0e80d chess-2.0b6.tar.gz 383951
+RMD160 cce4119f8b91c79ea83ea854b53cf3518e73f4a8 chess-2.0b6.tar.gz 383951
+SHA256 4d9938365965c109fc832109eec25d0a79d8c4b1ebd2025a4939ad88e75a396e chess-2.0b6.tar.gz 383951
+MD5 23b4fb5038232fc01c238a213cee5e63 emacs-chess-pieces-2.0.tar.bz2 297687
+RMD160 68caefa70dfe2071c1a5c3ce1564fec170be2a1c emacs-chess-pieces-2.0.tar.bz2 297687
+SHA256 c47278127ebcd8b4503fe4058317436757f795b1404cc02b883dce215eb1c1b0 emacs-chess-pieces-2.0.tar.bz2 297687
+MD5 86cd8cac846b0874e030692a8306d029 emacs-chess-sounds-2.0.tar.bz2 3390098
+RMD160 db4ef0bd29b2f415cea4438f31064cb6bad31dc0 emacs-chess-sounds-2.0.tar.bz2 3390098
+SHA256 32c3577c512157523bc40d514a1682d9381bd28b3d8f5788c22eef5ef2cf6257 emacs-chess-sounds-2.0.tar.bz2 3390098