summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-6.3.074.ebuild')
-rw-r--r--app-editors/vim/vim-6.3.074.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/vim/vim-6.3.074.ebuild b/app-editors/vim/vim-6.3.074.ebuild
new file mode 100644
index 000000000000..7fbacd6e195a
--- /dev/null
+++ b/app-editors/vim/vim-6.3.074.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/vim/vim-6.3.074.ebuild,v 1.1 2005/05/23 10:19:56 ciaranm Exp $
+
+inherit vim
+
+VIM_VERSION="6.3"
+VIM_ORG_PATCHES="vim-${PV}-patches.tar.bz2"
+VIM_GENTOO_PATCHES="vim-${PV}-gentoo-patches.tar.bz2"
+
+SRC_URI="${SRC_URI}
+ ftp://ftp.vim.org/pub/vim/unix/vim-${VIM_VERSION}.tar.bz2
+ nls? ( ftp://ftp.vim.org/pub/vim/extra/vim-${VIM_VERSION}-lang.tar.gz )
+ mirror://gentoo/${VIM_GENTOO_PATCHES}
+ mirror://gentoo/${VIM_ORG_PATCHES}"
+
+S=${WORKDIR}/vim${VIM_VERSION/.}
+DESCRIPTION="Vim, an improved vi-style text editor"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="${IUSE} nls"
+PROVIDE="virtual/editor"
+DEPEND="${DEPEND}
+ ~app-editors/vim-core-${PV}"
+RDEPEND="${RDEPEND}
+ ~app-editors/vim-core-${PV}
+ !app-editors/nvi"
+