summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/mp')
-rw-r--r--app-editors/mp/ChangeLog6
-rw-r--r--app-editors/mp/files/mp-5.2.0-make.patch11
-rw-r--r--app-editors/mp/mp-5.2.0.ebuild10
3 files changed, 19 insertions, 8 deletions
diff --git a/app-editors/mp/ChangeLog b/app-editors/mp/ChangeLog
index a98a7dab06c5..6e3cfadc3dcf 100644
--- a/app-editors/mp/ChangeLog
+++ b/app-editors/mp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-editors/mp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.79 2011/06/16 18:28:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/ChangeLog,v 1.80 2011/06/16 18:47:45 jer Exp $
+
+ 16 Jun 2011; Jeroen Roovers <jer@gentoo.org> mp-5.2.0.ebuild,
+ +files/mp-5.2.0-make.patch:
+ Fix parallel make (bug #326987).
*mp-5.2.0 (16 Jun 2011)
diff --git a/app-editors/mp/files/mp-5.2.0-make.patch b/app-editors/mp/files/mp-5.2.0-make.patch
new file mode 100644
index 000000000000..af51bc303384
--- /dev/null
+++ b/app-editors/mp/files/mp-5.2.0-make.patch
@@ -0,0 +1,11 @@
+--- a/makefile.in
++++ b/makefile.in
+@@ -29,7 +29,7 @@
+ $(MPDM)/libmpdm.a:
+ $(MAKE) -C $(MPDM)
+
+-$(MPSL)/libmpsl.a:
++$(MPSL)/libmpsl.a: $(MPDM)/libmpdm.a
+ $(MAKE) -C $(MPSL)
+
+ dep:
diff --git a/app-editors/mp/mp-5.2.0.ebuild b/app-editors/mp/mp-5.2.0.ebuild
index e940740008b7..4d2fa8744854 100644
--- a/app-editors/mp/mp-5.2.0.ebuild
+++ b/app-editors/mp/mp-5.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.2.0.ebuild,v 1.1 2011/06/16 18:28:14 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/mp/mp-5.2.0.ebuild,v 1.2 2011/06/16 18:47:45 jer Exp $
EAPI="3"
@@ -29,7 +29,8 @@ DEPEND="${RDEPEND}
dev-lang/perl"
src_prepare() {
- epatch "${FILESDIR}"/${PN}-5.1.1-prll.patch
+ epatch "${FILESDIR}"/${PN}-5.1.1-prll.patch \
+ "${FILESDIR}"/${PN}-5.2.0-make.patch
}
src_configure() {
@@ -62,11 +63,6 @@ src_configure() {
done
}
-src_compile() {
- # bug #326987
- emake -j1 || die "emake failed"
-}
-
src_install() {
dodir /usr/bin
sh config.sh --prefix="${EPREFIX}/usr"