summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kile/kile-2.1_beta2.ebuild')
-rw-r--r--app-editors/kile/kile-2.1_beta2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-editors/kile/kile-2.1_beta2.ebuild b/app-editors/kile/kile-2.1_beta2.ebuild
new file mode 100644
index 000000000000..60429a60ac6b
--- /dev/null
+++ b/app-editors/kile/kile-2.1_beta2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/kile/kile-2.1_beta2.ebuild,v 1.1 2009/10/22 21:01:11 ssuominen Exp $
+
+EAPI=2
+inherit kde4-base
+
+MY_P=${P/_beta/b}
+
+DESCRIPTION="A Latex Editor and TeX shell for kde"
+HOMEPAGE="http://kile.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+SLOT="4"
+IUSE="debug +pdf +png"
+
+RDEPEND="
+ || (
+ >=kde-base/okular-${KDE_MINIMAL}[pdf?,ps]
+ app-text/acroread
+ )
+ virtual/latex-base
+ virtual/tex-base
+ pdf? (
+ app-text/dvipdfmx
+ app-text/ghostscript-gpl
+ )
+ png? (
+ app-text/dvipng
+ media-gfx/imagemagick[png]
+ )
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ kde4-base_src_install
+
+ # TODO: come back later and see if there still is a collision
+ rm -f "${D}/${KDEDIR}"/share/{apps/katepart/syntax/{bibtex,latex}.xml,icons/hicolor/{64x64,22x22}/actions/{preview,output_win}.png}
+}