summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gummi/gummi-0.6.3.ebuild')
-rw-r--r--app-editors/gummi/gummi-0.6.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/gummi/gummi-0.6.3.ebuild b/app-editors/gummi/gummi-0.6.3.ebuild
new file mode 100644
index 000000000000..0e7e0a62f852
--- /dev/null
+++ b/app-editors/gummi/gummi-0.6.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.6.3.ebuild,v 1.1 2012/03/28 19:11:11 hwoarang Exp $
+
+EAPI=4
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/attachments/download/263/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ar ca cs da de el es fr it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell:2
+ >=dev-libs/glib-2.28.6
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}