summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/wordnet/wordnet-3.0-r2.ebuild')
-rw-r--r--app-dicts/wordnet/wordnet-3.0-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/app-dicts/wordnet/wordnet-3.0-r2.ebuild b/app-dicts/wordnet/wordnet-3.0-r2.ebuild
new file mode 100644
index 000000000000..fe7a198586e1
--- /dev/null
+++ b/app-dicts/wordnet/wordnet-3.0-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/wordnet/wordnet-3.0-r2.ebuild,v 1.1 2008/09/12 19:36:30 pva Exp $
+
+inherit flag-o-matic autotools
+
+DESCRIPTION="A lexical database for the English language"
+HOMEPAGE="http://wordnet.princeton.edu/"
+SRC_URI="ftp://ftp.cogsci.princeton.edu/pub/wordnet/${PV}/WordNet-${PV}.tar.gz
+ mirrors://gentoo/${P}-patchset-1.tar.bz2"
+LICENSE="Princeton"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+# In contrast to what the configure script seems to imply, Tcl/Tk is NOT optional.
+# cf. bug 163478 for details. (Yes, it's about 2.1 but it's still the same here.)
+DEPEND="dev-lang/tcl
+ dev-lang/tk"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/WordNet-${PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Don't install into PREFIX/dict but PREFIX/share/wordnet/dict
+ epatch "${WORKDIR}/${P}-dict-location.patch"
+ # Fixes bug 130024, make an additional shared lib
+ epatch "${WORKDIR}/${P}-shared-lib.patch"
+ # Don't install the docs directly into PREFIX/doc but PREFIX/doc/PN
+ epatch "${WORKDIR}/${P}-docs-path.patch"
+ epatch "${WORKDIR}"/${P}-CVE-2008-3908.patch #211491
+ epatch "${WORKDIR}"/${P}-CVE-2008-2149.patch #211491
+
+ # Don't install all the extra docs (html, pdf, ps) without doc USE flag.
+ use doc || sed -i -e "s:SUBDIRS =.*:SUBDIRS = man:" doc/Makefile.am
+
+ rm -f configure
+ eautoreconf
+}
+
+src_compile() {
+ append-flags -DUNIX -I${T}/usr/include
+
+ MAKEOPTS="-e"
+ PLATFORM=linux WN_ROOT="${T}/usr" \
+ WN_DICTDIR="${T}/usr/share/wordnet/dict" \
+ WN_MANDIR="${T}/usr/share/man" \
+ WN_DOCDIR="${T}/usr/share/doc/wordnet-${PV}" \
+ WNHOME="/usr/share/wordnet" \
+ econf
+ emake || die "emake Failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog INSTALL README || die "dodoc failed"
+}