summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/steghide/steghide-0.5.1.ebuild')
-rw-r--r--app-crypt/steghide/steghide-0.5.1.ebuild31
1 files changed, 18 insertions, 13 deletions
diff --git a/app-crypt/steghide/steghide-0.5.1.ebuild b/app-crypt/steghide/steghide-0.5.1.ebuild
index 3d1230ce0d0a..b14b0b69aafe 100644
--- a/app-crypt/steghide/steghide-0.5.1.ebuild
+++ b/app-crypt/steghide/steghide-0.5.1.ebuild
@@ -1,34 +1,39 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.11 2006/08/16 00:39:09 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/steghide/steghide-0.5.1.ebuild,v 1.12 2008/05/13 20:42:48 drac Exp $
-inherit eutils
+inherit autotools eutils
DESCRIPTION="A steganography program which hides data in various media files"
HOMEPAGE="http://steghide.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE=""
+IUSE="debug"
DEPEND=">=app-crypt/mhash-0.8.18-r1
- >=dev-libs/libmcrypt-2.5.7
- >=media-libs/jpeg-6b-r3
- >=sys-libs/zlib-1.1.4-r2"
+ >=dev-libs/libmcrypt-2.5.7
+ >=media-libs/jpeg-6b-r3
+ >=sys-libs/zlib-1.1.4-r2"
src_unpack(){
unpack ${A}
- epatch "${FILESDIR}"/${P}-gcc34.patch
- epatch "${FILESDIR}"/${P}-gcc4.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc34.patch \
+ "${FILESDIR}"/${P}-gcc4.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
}
src_compile() {
- econf || die "configure failed"
- epatch "${FILESDIR}"/fix-libtool-invocation.patch
- emake || die "make failed"
+ econf $(use_enable debug)
+ emake LIBTOOL="$(type -p libtool)" || die "emake failed."
}
src_install() {
- make DESTDIR="${D}" install || die "installation failed"
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}" install \
+ || die "emake install failed."
+ prepalldocs
}