summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca-tls/qca-tls-1.0-r4.ebuild')
-rw-r--r--app-crypt/qca-tls/qca-tls-1.0-r4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/qca-tls/qca-tls-1.0-r4.ebuild b/app-crypt/qca-tls/qca-tls-1.0-r4.ebuild
new file mode 100644
index 000000000000..0c3ec5180187
--- /dev/null
+++ b/app-crypt/qca-tls/qca-tls-1.0-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-tls/qca-tls-1.0-r4.ebuild,v 1.1 2008/01/18 16:47:09 ingmar Exp $
+
+inherit eutils
+
+DESCRIPTION="plugin to provide SSL/TLS capability to programs that utilize the Qt Cryptographic Architecture (QCA)"
+HOMEPAGE="http://delta.affinix.com/qca/"
+SRC_URI="http://delta.affinix.com/qca/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+#alpha amd64 and ppc64 need testing
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="=app-crypt/qca-1*
+ >=dev-libs/openssl-0.9.6i"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/qca-pathfix.patch
+ epatch "${FILESDIR}"/qca-openssl-0.9.8.patch
+}
+
+src_compile() {
+ ./configure || die "configure failed"
+ sed -i \
+ -e "/^CFLAGS/s:$: ${CFLAGS}:" \
+ -e "/^CXXFLAGS/s:$: ${CXXFLAGS}:" \
+ -e "/-strip/d" \
+ Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "make install failed"
+
+ dodoc README
+}