summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild')
-rw-r--r--app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild25
1 files changed, 6 insertions, 19 deletions
diff --git a/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild b/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild
index f2439b142eb8..cd9e222b5767 100644
--- a/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild
+++ b/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild,v 1.8 2009/07/21 16:49:41 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/qca-logger/qca-logger-2.0.0_beta2.ebuild,v 1.9 2009/08/19 13:54:59 betelgeuse Exp $
+
+EAPI="2"
inherit eutils qt4
@@ -16,26 +18,12 @@ SLOT="2"
KEYWORDS="alpha amd64 ia64 ~ppc64 sparc x86 ~x86-fbsd"
IUSE="debug"
-DEPEND=">=app-crypt/qca-${QCA_VER}"
+DEPEND=">=app-crypt/qca-${QCA_VER}[debug?]"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
-pkg_setup() {
- if use debug && ! built_with_use ">=app-crypt/qca-${QCA_VER}" debug; then
- echo
- eerror "You are trying to compile ${PN} with USE=\"debug\""
- eerror "while qca is built without this flag. It will not work."
- echo
- eerror "Possible solutions to this problem are:"
- eerror "a) install ${PN} without debug USE flag"
- eerror "b) re-emerge qca with debug USE flag"
- echo
- die "can't emerge ${PN} with debug USE flag"
- fi
-}
-
-src_compile() {
+src_configure() {
# cannot use econf because of non-standard configure script
./configure \
--qtdir=/usr \
@@ -44,10 +32,9 @@ src_compile() {
|| die "configure failed"
eqmake4 ${PN}.pro
- emake || die "make failed"
}
src_install() {
emake INSTALL_ROOT="${D}" install || die "make install failed"
- dodoc README
+ dodoc README || die
}